Bug 59338 - (440GX)RH7.2 hangs loading aic7xxx driver
(440GX)RH7.2 hangs loading aic7xxx driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-05 15:34 EST by PH Oger
Modified: 2007-04-18 12:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 21:10:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description PH Oger 2002-02-05 15:34:24 EST
Description of Problem:
I can't install the RH7.2 distro from the CDROM. I have an Adaptec 2930 CU 
SCSI PCI Adapter with 2 attached drives, a YAMAHA cdwriter and a PIONEER 
dvdrom.
The install hangs loading the aic7xxx module.
I tried without success the noprobe boot option then manualy selecting the 
regular aic7xxx module and even the experimental aic7xxx_mod module.
I also tried the apic boot option, said to work for some people experiencing 
aic7xxx problems during install. Didn't work either.
I decided to make a custom RH7.2 install floppy disk using the latest revision 
of the aic7xxx module (6.2.4).
This is the one I use on my RH7.0 linux box with a custom 2.4.17 kernel. It 
works fine.
So I patched the kernel 2.4.7 kernel (RH7.2) with the aic7xxx rev 6.2.4 code.
I had to replace vmlinuz in the boot.img and files aic7xxx.o, scsi_mod.o, 
sd_mod.o and sr_mod.o in the module.cgz file stored in the initrd.img .
Result: the scsi driver is loaded correctly but the install fails to find my 
Redhat CDROM.
Here is an excerpt of the messages printed on the consoles #3 and #4.

console #3:
* found suggestion of aic7xxx
* found aic7xxx device
* found suggestion of usb-ohci
* found devices justProbe is 0
* going to insmod aic7xxx.o (path is NULL)
* trying to mount device scd0
* loopfd is 7
* failed to mount loop: No such device
* trying to mount device scd1

console #4:
<6> loop: loaded (max 8 devices)
.
.
.
<6> SCSI subsystem driver Revision : 1.00
<6> PCI : Found IRQ 11 for device 00:08.0
<6> scsi0: Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.4
<4>        <Adaptec-2930CU SCSI adapter>
<4>        aic7860 : Ultra Single Channel A, SCSI Id=7, 3/253 SCBs
<4>
<4> Vendor: YAMAHA Model: CRW8824S Rev:1.00
<4> Type:   CD-ROM                 ANSI SCSI revision: 02
<4> (scsi0.A:0) 20.000MB/s transfers (20.000MHz, offset 15)
<4> Vendor: PIONEER Model: DVD-ROM DVD-305 Rev:1.03
<4> Type:   CD-ROM                 ANSI SCSI Revision: 02
<4> (scsi1:A:1) 20.000MB/s transfers (20.000MHz, offset 15)
<4> Attached SCSI CD-ROM sr0 at SCSI 0, channel 0, id 0, lun 0
<4> Attached SCSI CD-ROM sr1 at SCSI 0, channel 0, id 1, lun 0
<4> sr0: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
<6> Uniform CD-ROM driver Revision: 3.12
<4> sr1: scsi3-mmc drive: 16x/40x cd/rw xa/form2 cdda tray
<7> VFS: Disk change detected on device sr(11,0)
<7> ISO 9660 Extensions : Microsoft Joliet Level 3
<7> ISO 9660 Extensions : RRIP_1991A
<4> Unable to identify CD-ROM format
<4> sr1: CD-ROM not ready. Make sure there is a disc in the drive.
<6> cdrom: open failed
<7> VFS: Disk change detected on device sr(11,1)

I got the messages above with the RH7.2 install CD #1 in my cdwriter (SCSI 
id=0). I checked it neither worked with the CD in my dvdrom.

I also tried to make a install floppy disk with a 2.4.17 kernel. I got exactly 
the same result. Install reports "I could not find a RedHat linux CDROM in any 
of your CDROM drives. Please insert the RedHat CD and press OK to retry."

Among other things, I wonder why I get the message "failed to mount loop: No 
such device" as long as I also get the message "<6> loop: loaded (max 8 
devices).

Well, I might leave out an important feature in the kernel configuration. 
Could anyone help me ?

Thanks in advance.

Pierre-Hugues Oger


Version-Release number of selected component (if applicable): RH7.2 Install


How Reproducible: Always


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Tim Gladding 2002-02-21 18:26:06 EST
Try "linux apic" at the cd boot prompt.  It'll (probably) install then.

Now if only I could figure out how to make it reboot without hanging.  Doing 
a "linux apic" at the next prompt fails :(
Comment 2 Tim Gladding 2002-03-02 17:46:53 EST
Well, I found a way around my problem.. maybe this will help you too.

Install using "linux apic" at the first boot prompt.  When everything is 
installed and the machine reboots select "linux rescue".  Let the rescue shell 
prompt come up then cp /mnt/source/Redhat/RPMS/*-smp-* /mnt/sysimage/tmp/, 
chroot /mnt/sysimage and rpm -Uvh /tmp/<the right smp kernel for you>.  Then 
reboot and make sure you select the newly installed smp kernel.

I only have 1 processor in this box (a Data General 1400) but it runs just 
fine :)
Comment 3 Jeremy Katz 2002-03-14 16:55:04 EST
It fails because your updated initrd doesn't have all of the proper modules; you
should really go off of the BOOT kernel config and update from there.  

Assigning to kernel for the fact that the old driver didn't work
Comment 4 Alan Cox 2003-06-07 21:10:08 EDT
Red Hat 9 should handle 440GX better as we finally got some needed info from Intel

Note You need to log in before you can comment on or make changes to this bug.