Bug 593384 - augeas will be used in apache plugin only when it is set in the plugin configuration
Summary: augeas will be used in apache plugin only when it is set in the plugin config...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Agent   
(Show other bugs)
Version: 3.0.0
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: Filip Drabek
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: jon24-apache
TreeView+ depends on / blocked
 
Reported: 2010-05-18 17:29 UTC by Filip Drabek
Modified: 2010-08-12 16:48 UTC (History)
0 users

Fixed In Version: 2.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-12 16:48:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Filip Drabek 2010-05-18 17:29:51 UTC

Comment 1 Filip Drabek 2010-05-28 13:18:57 UTC
commit e023d52bfd9b361f52e74a4b9acea8c0b04e5b64

Comment 2 Corey Welton 2010-06-02 19:06:16 UTC
How do we test this?  Does this mean that we should not see augeas get hit on things such as Operations, etc.?

Comment 3 Filip Drabek 2010-06-02 20:24:34 UTC
-Discovery of apache (Server and Virtual Hosts) works without augeas.
IfModules and Directories are discovered only when augeas is enabled.
-Operations works without augeas.
- please test the functionality without installed augeas on linux machine.
- please test the functionality with old augeas version installed on the linux machine (the augeas is bundeled with agent and the right version of augeas should be used automatically)
- please test it also on Windows machine (augeas will not work there)

Comment 4 Corey Welton 2010-06-07 17:13:19 UTC
I have noted some problems to Filip that I have had, regarding discovery on Linux systems without augeas and on Windows systems.  Still trying to wade through these issues.

Comment 5 Corey Welton 2010-06-07 18:03:38 UTC
Update: on a separate linux system, w/ older (and subsequently, no) augeas installed

* I was able to detect apache
* run ops
* did see VirtualHosts appear
* did not see IfModules and Directories appear until augeas was enabled
 
So I think we are good wrt Linux.  Windows may be a separate issue but not a blocker at this point.

Comment 6 Corey Welton 2010-06-09 15:16:03 UTC
QA Verified.

Comment 7 Corey Welton 2010-08-12 16:48:15 UTC
Mass-closure of verified bugs against JON.


Note You need to log in before you can comment on or make changes to this bug.