Bug 593402 - Cobbler-web breaks /rpc/api over http (which breaks taskomatic)
Summary: Cobbler-web breaks /rpc/api over http (which breaks taskomatic)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server   
(Show other bugs)
Version: 1.0
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: space16
TreeView+ depends on / blocked
 
Reported: 2010-05-18 18:05 UTC by Justin Sherrill
Modified: 2011-12-22 16:50 UTC (History)
7 users (show)

Fixed In Version: spacewalk-backend-1.6.12-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-22 16:50:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin Sherrill 2010-05-18 18:05:24 UTC
1.  Install spacewalk
2.  Install cobbler-web
3.  restart spacewalk
4.  see if taskomatic is up (It won't be)
5.  see if you can access http://localhost/rpc/api   via xmlrpc (You won't be able to).


We need to investigate why cobbler-web's http config is breaking spacewalk.

Comment 1 Jan Pazdziora 2010-11-19 16:05:44 UTC
Mass-moving to space13.

Comment 2 Erik van Pienbroek 2010-11-23 13:00:23 UTC
I think this is caused by the fact that both the cobbler_web.conf and zz-spacewalk-server.conf contain a <VirtualHost> section. The cobbler_web.conf specifies one for port 80 (<VirtualHost *:80>) while the zz-spacewalk-server.conf defines one for the default (it's just <VirtualHost>).

As the VirtualHost for port 80 (as defined in the cobbler_web.conf) has preference over the default VirtualHost (as defined in zz-spacewalk-server.conf) the rewrite engine doesn't get enabled for port 80. This results in breakage of the spacewalk rewrite rules which are mentioned in zz-spacewalk-www.conf.

A simple solution to this would be to adjust the cobbler_web.conf to something like this:

<VirtualHost *:80>

RewriteEngine on
RewriteOptions inherit

...

</VirtualHost>

With this change spacewalk works fine again. A side effect of this is that apache complains on startup about the <VirtualHost> mentioned in zz-spacewalk-server.conf:
[Tue Nov 23 13:49:23 2010] [warn] _default_ VirtualHost overlap on port 80, the first has precedence

Comment 3 Miroslav Suchý 2011-04-11 07:34:19 UTC
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.

Comment 4 Miroslav Suchý 2011-04-11 07:37:30 UTC
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.

Comment 5 Jan Pazdziora 2011-07-20 11:52:57 UTC
Aligning under space16.

Comment 6 Clifford Perry 2011-08-05 13:00:52 UTC
We do not support cobbler-web installation on Spacewalk. Maybe we should investigate adding a conflicts statement into rpm spec file until someone implements code to make this work side-by-side correctly. 

Cliff

Comment 7 Michael Mráka 2011-08-19 08:12:46 UTC
Put a conflict into rpm for now
commit fe6d334ff5bc86608b944fdc3300f115e78da54d
    593402 - cobbler-web is known to break our configuration

Comment 8 Milan Zázrivec 2011-12-22 16:50:52 UTC
Spacewalk 1.6 has been released.


Note You need to log in before you can comment on or make changes to this bug.