Bug 593406 - recent updates have ruined connections using preshared rsasigkeys
Summary: recent updates have ruined connections using preshared rsasigkeys
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openswan
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Avesh Agarwal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 18:08 UTC by QingLong
Modified: 2012-01-16 18:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-16 18:34:52 UTC
Type: ---


Attachments (Terms of Use)

Description QingLong 2010-05-18 18:08:45 UTC
Description of problem:
I had quite well working openswan-to-openswan tunnel using rsasig authentication prior to recent updates. The 2.6.24-3 had ruined it totally. Later 2.6.25-1 has not repaired the damage.

Version-Release number of selected component (if applicable):
2.6.24-4, 2.6.25-1

How reproducible:
100%

Steps to Reproduce:
1.Have working pair of networks interconnected via rsasig authenticated tunnel.
  The versions should be less than 2.6.24-3.
2.Run `yum update' and get openswan updated to 2.6.24-3 or later (2.6.25-1) of at least on of the peers.
3.Get cert8.db, key3.db and secmod.db junk in /etc/ipsec.d/ and malfunctioning ipsec machinery.

Actual results:
FFFFUCK!!!

Expected results:
Updates MUST leave correctly configured systems working!
Updates should never been done in such a lame m$ way!

Additional info:
There are messages in syslog that I think are dealt with the problem:
Signature check (on rsasigkey-id-here) failed (wrong key?); tried *peer-rsasigkey-first-numbers-here

Attempt to recover (?) the key in hostkey.secrets with the aid of `ipsec rsasigkey --oldkey key.backup' fails as `ipsec rsasigkey' refuses to understand the `--oldkey' option (despite man page).

Comment 1 Avesh Agarwal 2010-05-18 18:23:39 UTC
Could you please set environment variable NSS_DEFAULT_DB_TYPE="sql" like

export NSS_DEFAULT_DB_TYPE="sql" 

And then please test your old setup again.

Comment 2 QingLong 2010-06-16 11:21:45 UTC
 That hasn't helped. I stil have:
|
| Can't find the private key from the NSS CERT (err -12285)
|
 on the ``updated'' side of the demolished connection and
|
| Signature check (on xxx@yyy.su) failed (wrong key?); tried *peer-rsasigkey-first-numbers-here
|
 on the other side.
 AFAICS the key had not been added to those new db files.
 How can I do it by hand (remember that `rsasigkey --oldkey' doesn't work)?

Comment 3 Bug Zapper 2010-11-03 14:37:50 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Bug Zapper 2010-12-03 14:34:31 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 5 QingLong 2011-02-04 22:57:21 UTC
This ugly bug is still there in Fedora 14.
Moreover now I cannot generate new hostkey with `ipsec newhostkey'.
It says
|
| ipsec rsasigkey: could not authenticate to token 'NSS Certificate DB'
|
(All the prepartions (certutil, modutil, nsspassword creation) has been done.)
Setting NSS_DEFAULT_DB_TYPE='sql' doesn't help.
So now I can neither use my old key (as the --oldkey does not work),
nor can I create a new one. Das ist fantastiche!
What the hell is going on with this stuff?

Comment 6 Paul Wouters 2011-02-08 18:20:02 UTC
This is a real migration problem for people using openswan that had raw rsa keys and did not get converted to NSS on upgrade.

The README.NSS is also not up to date it seems. What we really need is some "ipsec nss" command that helps people convert to the new setup

Comment 7 QingLong 2011-02-08 23:19:43 UTC
>
> This is a real migration problem for people using openswan
> that had raw rsa keys and did not get converted to NSS on upgrade.
>
   I have tried to generate new keys for fresh openswan installation with NSS
but failed, see above. Do you mean raw RSA keys are no longer supported?
Should all of us migrate to the ``certificates'' mess? OMG!
That machinery is almost always useless overkill.

Comment 8 QingLong 2011-02-13 02:00:51 UTC
 I wrote
>
> tried to generate new keys for fresh openswan installation with NSS but failed,
>|
>| ipsec rsasigkey: could not authenticate to token 'NSS Certificate DB'
>|
>
   And there is now surprise as no such token exists in the db.
 The `modutil -list' shows:
|
| Listing of PKCS #11 Modules
| -----------------------------------------------------------
|   1. NSS Internal FIPS PKCS #11 Module
|          slots: 1 slot attached
|         status: loaded
|
|          slot: NSS FIPS 140-2 User Private Key Services
|         token: NSS FIPS 140-2 Certificate DB
| -----------------------------------------------------------
|
 The token is `NSS FIPS 140-2 Certificate DB' rather than 'NSS Certificate DB'!
 So how this is supposed to work at all?

 Surely, this is NOT a migration problem.


Note You need to log in before you can comment on or make changes to this bug.