This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 59341 - popt might need to include <values.h>
popt might need to include <values.h>
Status: CLOSED UPSTREAM
Product: Red Hat Raw Hide
Classification: Retired
Component: popt (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-05 16:40 EST by Jeff Johnson
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 17:43:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Johnson 2002-02-05 16:40:21 EST
I had occasion to compile popt today on my 2.4.17 linux system. By way of
+background, it's a fairly stock CRUX linux install with gcc 2.95.3 and glibc
+2.2.4. The compile in popt.c failed due to the unrecognized symbols FLT_MAX
and+FLT_MIN. This was easily fixed by adding "#include <values.h>" near the top
of
+the source file. I just thought you guys might like to know.
Comment 1 Bill Nottingham 2005-09-29 17:43:46 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

For RPM issues, please try a current release such as Fedora Core 4; if bugs
persist, please open a new issue.

Note You need to log in before you can comment on or make changes to this bug.