Bug 593417 - SELinux is preventing /usr/sbin/hald "read" access on /usr/share/hal/fdi/preprobe.
SELinux is preventing /usr/sbin/hald "read" access on /usr/share/hal/fdi...
Status: CLOSED DUPLICATE of bug 593413
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:e16f1aeb996...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 14:28 EDT by Brian Whitehead
Modified: 2010-05-18 15:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 15:19:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Whitehead 2010-05-18 14:28:11 EDT
Summary:

SELinux is preventing /usr/sbin/hald "read" access on
/usr/share/hal/fdi/preprobe.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by hald. It is not expected that this access is
required by hald and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:hald_t:s0
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /usr/share/hal/fdi/preprobe [ dir ]
Source                        hald
Source Path                   /usr/sbin/hald
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           hal-0.5.13-9.fc12
Target RPM Packages           hal-0.5.13-9.fc12
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Tue 18 May 2010 01:18:03 PM CDT
Last Seen                     Tue 18 May 2010 01:18:03 PM CDT
Local ID                      947913fc-be95-44d7-b532-50fd5f5e2e80
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274206683.219:10): avc:  denied  { read } for  pid=1443 comm="hald" name="preprobe" dev=dm-0 ino=64526 scontext=system_u:system_r:hald_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1274206683.219:10): arch=c000003e syscall=254 success=yes exit=1 a0=b a1=446d0e a2=20000fc6 a3=20 items=0 ppid=1442 pid=1443 auid=4294967295 uid=68 gid=483 euid=68 suid=68 fsuid=68 egid=483 sgid=483 fsgid=483 tty=(none) ses=4294967295 comm="hald" exe="/usr/sbin/hald" subj=system_u:system_r:hald_t:s0 key=(null)



Hash String generated from  catchall,hald,hald_t,user_home_t,dir,read
audit2allow suggests:

#============= hald_t ==============
allow hald_t user_home_t:dir read;
Comment 1 Daniel Walsh 2010-05-18 15:19:00 EDT

*** This bug has been marked as a duplicate of bug 593413 ***

Note You need to log in before you can comment on or make changes to this bug.