Bug 593423 - SELinux is preventing /bin/grep "read" access on /usr/share/locale/locale.alias.
Summary: SELinux is preventing /bin/grep "read" access on /usr/share/locale/local...
Keywords:
Status: CLOSED DUPLICATE of bug 593413
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:30f71bf7038...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 18:48 UTC by Brian Whitehead
Modified: 2010-05-18 19:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-18 19:20:23 UTC
Type: ---


Attachments (Terms of Use)

Description Brian Whitehead 2010-05-18 18:48:58 UTC
Summary:

SELinux is preventing /bin/grep "read" access on /usr/share/locale/locale.alias.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by grep. It is not expected that this access is
required by grep and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:mysqld_safe_t:s0
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /usr/share/locale/locale.alias [ file ]
Source                        grep
Source Path                   /bin/grep
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           grep-2.6.3-1.fc12
Target RPM Packages           glibc-common-2.11.1-6
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Tue 18 May 2010 01:18:05 PM CDT
Last Seen                     Tue 18 May 2010 01:18:05 PM CDT
Local ID                      ecb9c349-5887-4aed-9df0-4b1ade8e5390
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274206685.517:16): avc:  denied  { read } for  pid=1688 comm="grep" name="locale.alias" dev=dm-0 ino=92187 scontext=system_u:system_r:mysqld_safe_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1274206685.517:16): avc:  denied  { open } for  pid=1688 comm="grep" name="locale.alias" dev=dm-0 ino=92187 scontext=system_u:system_r:mysqld_safe_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1274206685.517:16): arch=c000003e syscall=2 success=yes exit=68719476864 a0=7fff24c37a90 a1=0 a2=1b6 a3=2 items=0 ppid=1684 pid=1688 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="grep" exe="/bin/grep" subj=system_u:system_r:mysqld_safe_t:s0 key=(null)



Hash String generated from  catchall,grep,mysqld_safe_t,user_home_t,file,read
audit2allow suggests:

#============= mysqld_safe_t ==============
allow mysqld_safe_t user_home_t:file { read open };

Comment 1 Daniel Walsh 2010-05-18 19:20:23 UTC

*** This bug has been marked as a duplicate of bug 593413 ***


Note You need to log in before you can comment on or make changes to this bug.