Bug 593424 - SELinux is preventing /usr/bin/postgres "read" access on /usr/share/zoneinfo.
SELinux is preventing /usr/bin/postgres "read" access on /usr/share/zone...
Status: CLOSED DUPLICATE of bug 593413
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:a24c98d4b71...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 14:49 EDT by Brian Whitehead
Modified: 2010-05-18 15:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 15:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Whitehead 2010-05-18 14:49:31 EDT
Summary:

SELinux is preventing /usr/bin/postgres "read" access on /usr/share/zoneinfo.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by postmaster. It is not expected that this
access is required by postmaster and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:postgresql_t:s0
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                /usr/share/zoneinfo [ dir ]
Source                        postmaster
Source Path                   /usr/bin/postgres
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           postgresql-server-8.4.3-1.fc12
Target RPM Packages           tzdata-2010i-1.fc12
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Tue 18 May 2010 01:18:08 PM CDT
Last Seen                     Tue 18 May 2010 01:18:08 PM CDT
Local ID                      8cffab0f-a77c-48c4-95bb-1743a91da8cd
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274206688.512:22): avc:  denied  { read } for  pid=1917 comm="postmaster" name="zoneinfo" dev=dm-0 ino=8272 scontext=system_u:system_r:postgresql_t:s0 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1274206688.512:22): arch=c000003e syscall=2 success=yes exit=73014444160 a0=7fff4e499290 a1=90800 a2=1f a3=9 items=0 ppid=1 pid=1917 auid=4294967295 uid=26 gid=26 euid=26 suid=26 fsuid=26 egid=26 sgid=26 fsgid=26 tty=(none) ses=4294967295 comm="postmaster" exe="/usr/bin/postgres" subj=system_u:system_r:postgresql_t:s0 key=(null)



Hash String generated from  catchall,postmaster,postgresql_t,user_home_dir_t,dir,read
audit2allow suggests:

#============= postgresql_t ==============
allow postgresql_t user_home_dir_t:dir read;
Comment 1 Daniel Walsh 2010-05-18 15:20:16 EDT

*** This bug has been marked as a duplicate of bug 593413 ***

Note You need to log in before you can comment on or make changes to this bug.