Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 593428 - SELinux is preventing /usr/libexec/fprintd "getattr" access on /usr/share/locale/locale.alias.
SELinux is preventing /usr/libexec/fprintd "getattr" access on /usr/shar...
Status: CLOSED DUPLICATE of bug 593420
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:89a406b57a1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 14:55 EDT by Brian Whitehead
Modified: 2010-05-18 15:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 15:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Whitehead 2010-05-18 14:55:18 EDT
Summary:

SELinux is preventing /usr/libexec/fprintd "getattr" access on
/usr/share/locale/locale.alias.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by fprintd. It is not expected that this access
is required by fprintd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:fprintd_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /usr/share/locale/locale.alias [ file ]
Source                        fprintd
Source Path                   /usr/libexec/fprintd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           fprintd-0.1-16.git04fd09cfa.fc12
Target RPM Packages           glibc-common-2.11.1-6
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Tue 18 May 2010 01:18:41 PM CDT
Last Seen                     Tue 18 May 2010 01:18:41 PM CDT
Local ID                      b92b0f9b-538d-4854-b0ed-c4a428d51aa4
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274206721.992:68): avc:  denied  { getattr } for  pid=2699 comm="fprintd" path="/usr/share/locale/locale.alias" dev=dm-0 ino=92187 scontext=system_u:system_r:fprintd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1274206721.992:68): arch=c000003e syscall=5 success=yes exit=0 a0=3 a1=7fff2fdb9880 a2=7fff2fdb9880 a3=0 items=0 ppid=2698 pid=2699 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="fprintd" exe="/usr/libexec/fprintd" subj=system_u:system_r:fprintd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,fprintd,fprintd_t,user_home_t,file,getattr
audit2allow suggests:
audit2allow is not installed.
Comment 1 Daniel Walsh 2010-05-18 15:25:51 EDT

*** This bug has been marked as a duplicate of bug 593420 ***

Note You need to log in before you can comment on or make changes to this bug.