Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 593437 - SELinux is preventing /usr/bin/python "setattr" access on repomd.xml.old.tmp.
SELinux is preventing /usr/bin/python "setattr" access on repomd.xml.old...
Status: CLOSED DUPLICATE of bug 593432
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:08c65719f22...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 15:02 EDT by Brian Whitehead
Modified: 2010-05-18 15:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 15:23:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Whitehead 2010-05-18 15:02:23 EDT
Summary:

SELinux is preventing /usr/bin/python "setattr" access on repomd.xml.old.tmp.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by yum. It is not expected that this access is
required by yum and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:munin_t:s0
Target Context                system_u:object_r:rpm_var_cache_t:s0
Target Objects                repomd.xml.old.tmp [ file ]
Source                        yum
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.2-4.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Tue 18 May 2010 01:20:27 PM CDT
Last Seen                     Tue 18 May 2010 01:20:27 PM CDT
Local ID                      16bf62e2-8a7f-4fb0-ad88-7a3aafacba23
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274206827.622:145): avc:  denied  { setattr } for  pid=4055 comm="yum" name="repomd.xml.old.tmp" dev=dm-0 ino=917797 scontext=system_u:system_r:munin_t:s0 tcontext=system_u:object_r:rpm_var_cache_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1274206827.622:145): arch=c000003e syscall=235 success=yes exit=0 a0=32db510 a1=7fff74809f30 a2=33459b0e40 a3=7fff74809cf8 items=0 ppid=4054 pid=4055 auid=4294967295 uid=0 gid=468 euid=0 suid=0 fsuid=0 egid=468 sgid=468 fsgid=468 tty=(none) ses=4294967295 comm="yum" exe="/usr/bin/python" subj=system_u:system_r:munin_t:s0 key=(null)



Hash String generated from  catchall,yum,munin_t,rpm_var_cache_t,file,setattr
audit2allow suggests:
audit2allow is not installed.
Comment 1 Daniel Walsh 2010-05-18 15:23:26 EDT

*** This bug has been marked as a duplicate of bug 593432 ***

Note You need to log in before you can comment on or make changes to this bug.