Bug 593441 - SELinux is preventing /usr/sbin/smartd "read" access on /usr/share/zoneinfo/GMT.
Summary: SELinux is preventing /usr/sbin/smartd "read" access on /usr/share/zonei...
Keywords:
Status: CLOSED DUPLICATE of bug 593420
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:1a54137bced...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 19:04 UTC by Brian Whitehead
Modified: 2010-05-18 19:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-18 19:27:10 UTC
Type: ---


Attachments (Terms of Use)

Description Brian Whitehead 2010-05-18 19:04:25 UTC
Summary:

SELinux is preventing /usr/sbin/smartd "read" access on /usr/share/zoneinfo/GMT.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by smartd. It is not expected that this access
is required by smartd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:fsdaemon_t:s0
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /usr/share/zoneinfo/GMT [ file ]
Source                        smartd
Source Path                   /usr/sbin/smartd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           smartmontools-5.39.1-1.fc12
Target RPM Packages           tzdata-2010i-1.fc12
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Alert Count                   4
First Seen                    Tue 18 May 2010 01:18:24 PM CDT
Last Seen                     Tue 18 May 2010 01:48:24 PM CDT
Local ID                      5dbb8a63-9284-484d-9ed4-e9bf1373e4a2
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274208504.912:623): avc:  denied  { read } for  pid=2597 comm="smartd" name="GMT" dev=dm-0 ino=1802 scontext=system_u:system_r:fsdaemon_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1274208504.912:623): avc:  denied  { open } for  pid=2597 comm="smartd" name="GMT" dev=dm-0 ino=1802 scontext=system_u:system_r:fsdaemon_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1274208504.912:623): arch=c000003e syscall=2 success=yes exit=68719476864 a0=7fff161496e0 a1=0 a2=1b6 a3=2 items=0 ppid=1 pid=2597 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="smartd" exe="/usr/sbin/smartd" subj=system_u:system_r:fsdaemon_t:s0 key=(null)



Hash String generated from  catchall,smartd,fsdaemon_t,user_home_t,file,read
audit2allow suggests:
audit2allow is not installed.

Comment 1 Daniel Walsh 2010-05-18 19:27:10 UTC

*** This bug has been marked as a duplicate of bug 593420 ***


Note You need to log in before you can comment on or make changes to this bug.