Bug 593443 - SELinux is preventing /bin/dbus-daemon "read" access on /usr/share/dbus-1/system-services.
Summary: SELinux is preventing /bin/dbus-daemon "read" access on /usr/share/dbus-...
Keywords:
Status: CLOSED DUPLICATE of bug 593420
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:3ec9e97f397...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 19:21 UTC by Brian Whitehead
Modified: 2010-05-18 19:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-18 19:27:01 UTC
Type: ---


Attachments (Terms of Use)

Description Brian Whitehead 2010-05-18 19:21:01 UTC
Summary:

SELinux is preventing /bin/dbus-daemon "read" access on
/usr/share/dbus-1/system-services.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by dbus-daemon. It is not expected that this
access is required by dbus-daemon and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /usr/share/dbus-1/system-services [ dir ]
Source                        dbus-daemon
Source Path                   /bin/dbus-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dbus-1.2.16-9.fc12
Target RPM Packages           dbus-1.2.16-9.fc12
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Tue 18 May 2010 01:52:48 PM CDT
Last Seen                     Tue 18 May 2010 01:53:13 PM CDT
Local ID                      f1083e24-88db-4cfd-8f8d-1f49cf8cbf67
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274208793.669:744): avc:  denied  { read } for  pid=1333 comm="dbus-daemon" name="system-services" dev=dm-0 ino=19756 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1274208793.669:744): arch=c000003e syscall=2 success=yes exit=73014444160 a0=7fa2ec3224c0 a1=90800 a2=1 a3=0 items=0 ppid=1 pid=1333 auid=4294967295 uid=81 gid=81 euid=81 suid=81 fsuid=81 egid=81 sgid=81 fsgid=81 tty=(none) ses=4294967295 comm="dbus-daemon" exe="/bin/dbus-daemon" subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,dbus-daemon,system_dbusd_t,user_home_t,dir,read
audit2allow suggests:
audit2allow is not installed.

Comment 1 Daniel Walsh 2010-05-18 19:27:01 UTC

*** This bug has been marked as a duplicate of bug 593420 ***


Note You need to log in before you can comment on or make changes to this bug.