Bug 593447 - SELinux is preventing /usr/bin/lpstat.cups "read" access on /usr/share/locale/locale.alias.
SELinux is preventing /usr/bin/lpstat.cups "read" access on /usr/share/l...
Status: CLOSED DUPLICATE of bug 593420
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:b70369b8f40...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 15:25 EDT by Brian Whitehead
Modified: 2010-05-18 15:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 15:30:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Whitehead 2010-05-18 15:25:12 EDT
Summary:

SELinux is preventing /usr/bin/lpstat.cups "read" access on
/usr/share/locale/locale.alias.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by lpstat. It is not expected that this access
is required by lpstat and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:munin_services_plugin_t:s0
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /usr/share/locale/locale.alias [ file ]
Source                        lpstat
Source Path                   /usr/bin/lpstat.cups
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           cups-1.4.2-28.fc12
Target RPM Packages           glibc-common-2.11.1-6
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Alert Count                   28
First Seen                    Tue 18 May 2010 01:18:23 PM CDT
Last Seen                     Tue 18 May 2010 02:20:06 PM CDT
Local ID                      2f2f17cd-507c-4dc2-a8d2-725bc4ae619d
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274210406.171:1230): avc:  denied  { read } for  pid=19202 comm="lpstat" name="locale.alias" dev=dm-0 ino=92187 scontext=system_u:system_r:munin_services_plugin_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1274210406.171:1230): avc:  denied  { open } for  pid=19202 comm="lpstat" name="locale.alias" dev=dm-0 ino=92187 scontext=system_u:system_r:munin_services_plugin_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1274210406.171:1230): arch=c000003e syscall=2 success=yes exit=68719476864 a0=7fff284dc3c0 a1=0 a2=1b6 a3=2 items=0 ppid=19201 pid=19202 auid=4294967295 uid=485 gid=468 euid=485 suid=485 fsuid=485 egid=468 sgid=468 fsgid=468 tty=(none) ses=4294967295 comm="lpstat" exe="/usr/bin/lpstat.cups" subj=system_u:system_r:munin_services_plugin_t:s0 key=(null)



Hash String generated from  catchall,lpstat,munin_services_plugin_t,user_home_t,file,read
audit2allow suggests:
audit2allow is not installed.
Comment 1 Daniel Walsh 2010-05-18 15:30:43 EDT

*** This bug has been marked as a duplicate of bug 593420 ***

Note You need to log in before you can comment on or make changes to this bug.