Bug 593449 - SELinux is preventing /usr/bin/perl "ioctl" access on /usr/share/munin/plugins/diskstats.
SELinux is preventing /usr/bin/perl "ioctl" access on /usr/share/munin/p...
Status: CLOSED DUPLICATE of bug 593420
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:93b289be95e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 15:28 EDT by Brian Whitehead
Modified: 2010-05-18 15:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 15:30:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Whitehead 2010-05-18 15:28:13 EDT
Summary:

SELinux is preventing /usr/bin/perl "ioctl" access on
/usr/share/munin/plugins/diskstats.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by diskstats. It is not expected that this
access is required by diskstats and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:munin_t:s0
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /usr/share/munin/plugins/diskstats [ file ]
Source                        open_inodes
Source Path                   /bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           perl-5.10.0-87.fc12
Target RPM Packages           munin-node-1.4.4-1.fc12
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Alert Count                   32
First Seen                    Tue 18 May 2010 01:18:17 PM CDT
Last Seen                     Tue 18 May 2010 02:25:05 PM CDT
Local ID                      070dd946-11a4-4dcc-9c51-e625e863198c
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274210705.703:1318): avc:  denied  { ioctl } for  pid=20422 comm="diskstats" path="/usr/share/munin/plugins/diskstats" dev=dm-0 ino=1592499 scontext=system_u:system_r:munin_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1274210705.703:1318): arch=c000003e syscall=16 success=yes exit=68719476864 a0=3 a1=5401 a2=7fffe1477e70 a3=60 items=0 ppid=20209 pid=20422 auid=4294967295 uid=485 gid=468 euid=485 suid=485 fsuid=485 egid=468 sgid=468 fsgid=468 tty=(none) ses=4294967295 comm="diskstats" exe="/usr/bin/perl" subj=system_u:system_r:munin_t:s0 key=(null)



Hash String generated from  catchall,open_inodes,munin_t,user_home_t,file,ioctl
audit2allow suggests:
audit2allow is not installed.
Comment 1 Daniel Walsh 2010-05-18 15:30:28 EDT

*** This bug has been marked as a duplicate of bug 593420 ***

Note You need to log in before you can comment on or make changes to this bug.