Bug 593477 - SELinux is preventing /bin/bash "getattr" access on /etc/nsswitch.conf.
Summary: SELinux is preventing /bin/bash "getattr" access on /etc/nsswitch.conf.
Status: CLOSED DUPLICATE of bug 593473
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
(Show other bugs)
Version: 12
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:26ee85141db...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 21:36 UTC by Brian Whitehead
Modified: 2010-05-19 12:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-19 12:59:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Whitehead 2010-05-18 21:36:32 UTC
Summary:

SELinux is preventing /bin/bash "getattr" access on /etc/nsswitch.conf.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by uptime. It is not expected that this access
is required by uptime and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:munin_system_plugin_t:s0
Target Context                system_u:object_r:etc_t:s0
Target Objects                /etc/nsswitch.conf [ file ]
Source                        uptime
Source Path                   /bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.0.35-3.fc12
Target RPM Packages           glibc-2.11.1-6
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Alert Count                   69
First Seen                    Tue 18 May 2010 01:18:20 PM CDT
Last Seen                     Tue 18 May 2010 04:35:04 PM CDT
Local ID                      a9bdeaef-efc0-4757-8e54-924c1c7c4b75
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274218504.235:3564): avc:  denied  { getattr } for  pid=20333 comm="uptime" path="/etc/nsswitch.conf" dev=dm-0 ino=61041 scontext=system_u:system_r:munin_system_plugin_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1274218504.235:3564): arch=c000003e syscall=5 success=yes exit=68719476864 a0=3 a1=7ffffff67150 a2=7ffffff67150 a3=78 items=0 ppid=20230 pid=20333 auid=4294967295 uid=485 gid=468 euid=485 suid=485 fsuid=485 egid=468 sgid=468 fsgid=468 tty=(none) ses=4294967295 comm="uptime" exe="/bin/bash" subj=system_u:system_r:munin_system_plugin_t:s0 key=(null)



Hash String generated from  catchall,uptime,munin_system_plugin_t,etc_t,file,getattr
audit2allow suggests:
audit2allow is not installed.

Comment 1 Daniel Walsh 2010-05-19 12:59:48 UTC

*** This bug has been marked as a duplicate of bug 593473 ***


Note You need to log in before you can comment on or make changes to this bug.