Bug 59348 - Epson backend only produces grey scans
Epson backend only produces grey scans
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sane-backends (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-05 19:45 EST by Tethys
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 17:15:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested debug output (14.07 KB, text/plain)
2002-02-06 13:45 EST, Tethys
no flags Details

  None (edit)
Description Tethys 2002-02-05 19:45:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221

Description of problem:
When scanning using the Epson backend, colour scans come out in
greyscale only. This is with xsane, xscanimage and scanimage.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Scan a colour image
2.
3.
	

Actual Results:  The image comes out greyscale

Expected Results:  The image should scan in colour

Additional info:

I'm using an Epson GT7000 SCSI scanner, connected to a Tekram
DC-395UW SCSI controller. Kernel is 2.4.17, with Kurt Garloff's
Tekram driver patch.

This same setup (an earlier kernel, with the same patch) worked
fine on RH7.1 on the same machine. When I upgraded to 7.2, it
refused to scan in colour.

Using the SANE_DEBUG_EPSON environment variable didn't provide any
useful information that I could see.
Comment 1 Tim Waugh 2002-02-06 13:00:24 EST
Please try this:

SANE_DEBUG_EPSON=128 SANE_DEBUG_SANEI_SCSI=128 scanimage -L

and attach the output.
Comment 2 Tethys 2002-02-06 13:45:54 EST
Created attachment 44717 [details]
Requested debug output
Comment 3 Tim Waugh 2002-02-06 17:15:24 EST
Thanks.  Reported upstream.
Comment 4 Tethys 2002-02-06 17:45:06 EST
Problem solved. It *is* scanning in colour, it's just that the test image
I was scanning was very close to grey. The slight blueish tint in the
original image was being lost (presumably due to the limitations of the
scanner), and the resulting image came out grey. When I tried it with a
"normal" colour image, it works fine. Sorry for the false alarm...

Note You need to log in before you can comment on or make changes to this bug.