Bug 59350 - g450 redraws poorly when moving windows between workspaces
g450 redraws poorly when moving windows between workspaces
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 82777
  Show dependency treegraph
 
Reported: 2002-02-05 20:48 EST by Jonathan Larmour
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-15 04:43:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
XF86Config-4 (1.85 KB, text/plain)
2002-02-11 12:48 EST, Jonathan Larmour
no flags Details
XFree86 log (21.13 KB, text/plain)
2002-02-11 12:49 EST, Jonathan Larmour
no flags Details

  None (edit)
Description Jonathan Larmour 2002-02-05 20:48:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-21 i686)

Description of problem:
When dragging windows between workspaces with my G450 (just used with a single
head) with wireframe outlines, the wireframe bit stays drawn on the new
workspace.


This is with a fully up2date 7.2 release. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Ensure you are using "box" outlines when moving Windows: found in GNOME
control centre->Sawfish->Moving and Resizing->How windows being moved are
animated
2. Ensure you have multiple workspaces:
GNOME control centre->Sawfish->Workspaces
and under the Edge Flipping tag, ensure "Select the next desktop when the
pointer hits screen edge" is enabled, hitting the screen edge selects the next
workspace.
3. Make sure you have a bunch of windows up, on both workspaces (going from and
to) and drag one of the windows to the other one. 

It can be done with multiple viewports, not workspaces, but for some reason it
is less reliable, and only seems to cause the "box" to be left behind a little,
and only on the window being moved.

	

Actual Results:  The wireframe "box" is left partially drawn, even on existing
windows.


Expected Results:  No box :).


Additional info:
Comment 1 Jonathan Larmour 2002-02-06 21:45:55 EST
I've noticed a made a fundamental mistake in my description. Everywhere I
mention workspaces, I mean viewports and vice versa!
Comment 2 Mike A. Harris 2002-02-09 10:32:20 EST
Please attach your XFree86 log file, and config file using the link below.
I've got some potential troubleshooting tests we can try in order to find
a workaround for now, and also track down the source of the problem for
debugging.
Comment 3 Jonathan Larmour 2002-02-11 12:48:57 EST
Created attachment 45279 [details]
XF86Config-4
Comment 4 Jonathan Larmour 2002-02-11 12:49:48 EST
Created attachment 45280 [details]
XFree86 log
Comment 5 Jonathan Larmour 2002-02-11 12:50:52 EST
Attached config file and log as requested. Obviously just say if there's
anything else I can do to help.
Comment 6 Mike A. Harris 2002-12-21 17:19:24 EST
Sorry for not getting back to you on this, it somehow slipped between
the cracks.  ;o/

If this problem is still occuring for you, could you indicate if you've
tried RHL 7.3 or 8.0 yet or not and if the problem is present in either
release or not?  Also, I've got a new RHL 8.0 erratum candidate for testing
at ftp://people.redhat.com/mharris/testing/8.0/XFree86 which has some
Matrox fixes in it also for screen corruption issues.

If these problems persist, we can try disabling acceleration, DRI and
other things to pinpoint the source of the problem.

Thanks.
Comment 7 Mike A. Harris 2002-12-30 08:21:47 EST
Have you tried my latest packages with the updated mga driver?
Comment 8 Mike A. Harris 2003-04-15 04:43:23 EDT
Closing bug as CURRENTRELEASE and assuming that the problem no longer occurs
due to lack of feedback.  If the problem recurs, please report it in
XFree86.org's bugzilla at: http://bugs.xfree86.org and include a link here
to the URL.  You can reopen this bug if you like also so I can track the
upstream bug report.

Note You need to log in before you can comment on or make changes to this bug.