This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 59351 - mkbootdisk does not create serial console boot floppy disk
mkbootdisk does not create serial console boot floppy disk
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mkbootdisk (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
http://www.aarnet.edu.au/~gdt/serialc...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-05 23:00 EST by Glen Turner
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-08 14:48:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen Turner 2002-02-05 23:00:17 EST
Description of Problem:

(1) mkbootdisk uses SYSLINUX as the boot loader.  SYSLINUX has a
"serial" command but mkbootdisk has no parameter that inserts
this command.

(2) There is also no ability to add arbitrary kernel parameters.
Although this may be done from the SYSLINUX command line
it would be nicer if mkbootdisk allowed this, then an
emergency boot floppy would not fail starting a kernel.

The result of (1) is that boot disk's boot loader cannot be
controlled from a serial console.

The result of (2) is that an unattended reboot from a boot
diskette will not pass kernel parameters required for normal
operation.  This includes, but is not limited to, kernel
parameters required for the serial console.


Version-Release number of selected component (if applicable):

rpm -q mkbootdisk
mkbootdisk-1.4.2-3

How Reproducible:

Always

Steps to Reproduce:

1.Follow Remote-Serial-Console-HOWTO 2nd ed.
2.mkbootdisk --device /dev/fd0
3.Boot from floppy
4.Attempt to control SYSLINUX from serial port, say to add a kernel parameter.

Actual Results:

SYSLINUX does not communicate with the serial port.
Because of that no parameters can be passed to the kernel,
including those instructing the kernel to use the serial
port.

The remote serial console does not work when a boot disk
is used.

Expected Results:

(1) The emergency boot disk should communicate with the console,
even a serial console.  This may require the addition
of parameters to mkbootdisk.

(2) Emergency boot disks should boot a working kernel, even
when unattended.  Some installations require kernel
parameters to have a working kernel.  This may rqeuire
the addition of parameters to mkbootdisk, or for it
to examine /etc/lilo.conf or /boot/grub/menu.lst.

Additional Information:

Reporter is author of the 2nd edition of the
Remote-Serial-Console-HOWTO, currently in final
draft at
http://www.aarnet.edu.au/~gdt/serialconsole/

(1) mkbootdisk should at least have an option to insert a
"serial" directive into the first line of SYSLINUX.CFG.
This should allow the serial port, bit rate and
flow control to be selected.

eg: mkbootdisk --device /dev/fd0 --serial-port 0 --serial-speed 9600
--serial-flow-control modem ...

(2) mkbootdisk should also accept kernel parameters
eg: ...  --parameters 'console=ttyS0,9600n81' ...
This would be helpful for all users, not just those with
serial consoles.

Workaround is to modify SYSLINUX.CFG on boot floppies
created with mkbootdisk, or to alter the mkbootdisk
script itself.
Issue (1) is of lesser severity than issue (2).  Both
should be fixed as they limit the robustness of RHL
in data center deployments.
Comment 1 Matt Wilson 2002-12-14 19:51:30 EST
marking as enhancement
Comment 2 Brent Fox 2004-09-08 14:48:33 EDT
Closing since we don't make boot floppies anymore due to 2.6 kernel
size limitation.

Note You need to log in before you can comment on or make changes to this bug.