This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 59353 - "APM dmi blacklist can't be overruled"
"APM dmi blacklist can't be overruled"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-06 03:57 EST by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
cut down version of messages log file (2.95 KB, text/plain)
2002-02-06 23:35 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-02-06 03:57:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 95)

Description of problem:
When booting modprobe reports it can't locate block-major-2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH7.2 on a laptop
2.Boot machine
3.
	

Actual Results:  At boot and in messages modprobe line gives the error 
modprobe: Can't locate block-major-2. It does not appear to affect the running 
of the machine.

Additional info:

Hi 

I have installed rh7.2 on a desktop i586 p200mmx and this error does not occur. 
The other machine is a Sharp PX AX10 ultralight laptop p3 500. This error 
occurs everytime i boot the machine. It doesn't appear to affect the operation 
of linux but i don't know what it is looking for or even what a 'block-major-2' 
is.

[This part is not really a bug but assistance would be appreciated]
Also on this laptop, at bootup the kernel detects that it is a Sharp PC-PJ AX 
series then disables the APM. The reason it does this is i had trouble with APM 
with rh7.1 and details of the machine were asked for so as to disable the APM 
on boot. I would like to know if there is a way of getting the kernel to load 
the APM since later kernel versions may now work with this machine. I have 
tried apm=on with the loader [using GRUB] assuming i did it right

Thanks
Carl
Comment 1 Arjan van de Ven 2002-02-06 04:13:37 EST
block-major-2 is "/dev/fd0", eg the floppy drive. I suspect your laptop doesn't
have one built in and hence the kernel not being able to find one.... of course
that's harmless unless you actually have a floppy drive :(

apm=on is supposed to be the way to override the dmi data; if it doesn't work
then I'll investigate why.
Comment 2 Need Real Name 2002-02-06 23:35:35 EST
Created attachment 44817 [details]
cut down version of messages log file
Comment 3 Need Real Name 2002-02-06 23:49:35 EST
Hi

Your right, my laptop does not have a built in floppy it has a usb fdd which i
am still trying to workout how to mount. Any ideas:).

I tried the apm=on as a kernel command again as shown in the messages file
attached about line 12. I am not sure if i have done this right since i have not
used grub loader before. I edited the boot details at boot time.
ie
root (hd),2)
kernel /vmlinuz-2.4.7-10 ro root=/dev/hda5 apm=on
initrd /initrd-2.4.7-10.img

Assuming this is how to pass commands to the kernel, at about line 21 the kernel
detects the machine type as 
Sharp PC-PJ/AX machine detected. Disabling APM.

then it disables the APM. When i run apm as a command an error message reports
'No APM support in kernel'

Any help would be appreciated

Thanks
Carl
Comment 4 Arjan van de Ven 2002-02-11 11:01:59 EST
Changing the summary to represent the bug status
Comment 5 Bugzilla owner 2004-09-30 11:39:22 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.