Bug 593541 - werror and rerror is no supported when using -drive ... -device... options boot guests
werror and rerror is no supported when using -drive ... -device... options...
Status: CLOSED DUPLICATE of bug 565609
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 01:05 EDT by juzhang
Modified: 2010-05-19 03:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-19 03:14:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description juzhang 2010-05-19 01:05:53 EDT
Description of problem:
when using "-drive file=/root/zhangjunyi/rhel6_64_ide.qcow2,if=none,boot=on,cache=off,format=qcow2,id=test,werror=stop,rerror=stop -device ide-drive,drive=test" in stead of "-drive file=/root/zhangjunyi/rhel6_64_ide.qcow2,if=ide,boot=on,cache=off,werror=stop,rerror=stop,format=qcow2" lead to qemu-kvm aborted with the error "werror is no supported by this format".

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.53.el6
host kernel:2.6.32-25.el6.x86_64

How reproducible:


Steps to Reproduce:
1.boot guest
/usr/libexec/qemu-kvm  -no-hpet -usbdevice tablet -rtc-td-hack -m 2G -smp 2 -drive file=/root/zhangjunyi/rhel6_64_ide.qcow2,if=none,boot=on,cache=off,format=qcow2,id=test,werror=stop,rerror=stop -device ide-drive,drive=test -net nic,vlan=0,macaddr=22:11:22:45:66:97,model=virtio -net tap,vlan=0,script=/etc/qemu-ifup -uuid `uuidgen` -cpu qemu64,+sse2 -device virtio-balloon-pci -boot order=cn,menu=on -M rhel6.0.0 -monitor stdio -vnc :11


Actual results:
qemu-kvm was aborted with the error "werror is no supported by this format"

Expected results:
guest should be boot successful and  werror/rerror should be supported.

Additional info:
when using the following command boot guest,we can boot guest successfully and werror/rerror is supported. 

/usr/libexec/qemu-kvm  -no-hpet -usbdevice tablet -rtc-td-hack -m 2G -smp 2 -drive file=/root/zhangjunyi/rhel6_64_ide.qcow2,if=ide,boot=on,cache=off,werror=stop,rerror=stop -net nic,vlan=0,macaddr=22:11:22:45:66:97,model=virtio -net tap,vlan=0,script=/etc/qemu-ifup -uuid `uuidgen` -cpu qemu64,+sse2 -device virtio-balloon-pci -boot order=cn,menu=on -M rhel6.0.0 -monitor stdio -vnc :11
Comment 2 juzhang 2010-05-19 03:14:23 EDT
duplicate bz565609,close this issue,I will fellow up bz565609.

*** This bug has been marked as a duplicate of bug 565609 ***

Note You need to log in before you can comment on or make changes to this bug.