Bug 59355 - kword crashed
kword crashed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: koffice (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-06 06:18 EST by Tim Waugh
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-22 06:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2002-02-06 06:18:30 EST
Description of Problem:
kword just crashed while trying to save a file.

Version-Release number of selected component (if applicable):
koffice-2.0.0-0.cvs20020130.1
kdebase-3.0.0-0.cvs20020129.1
kdelibs-3.0.0-0.cvs20020128.3
qt-3.0.2-0.cvs20020118.2

How Reproducible:
Don't know.

Steps to Reproduce:
1. I was saving a file; I had just clicked 'ok' on the Save As.. dialog.

Actual Results:
Crash.

Expected Results:
Saved file. :-)

Additional Information:
Since this seems to be crashing in font-related code, perhaps the font I was
using for the document is relevant: I think it was Helmetcondensed [Xft].

Here is the backtrace:

(no debugging symbols found)...[New Thread 1024 (LWP 16269)]
0x4110cff9 in wait4 () from /lib/i686/libc.so.6
#0  0x4110cff9 in wait4 () from /lib/i686/libc.so.6
#1  0x4119b690 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40f38483 in waitpid () from /lib/i686/libpthread.so.0
#3  0x406f2aa9 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  0x40f367fc in pthread_sighandler () from /lib/i686/libpthread.so.0
#5  <signal handler called>
#6  0x4099ae8d in QFont::QFont(QFont const&) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#7  0x414d8849 in KWTextParag::saveFormat(QDomDocument&, KoTextFormat*,
KoTextFormat*, int, int) () from /usr/lib/kde3/libkwordpart.so
#8  0x414da431 in KWTextParag::save(QDomElement&, int, int, bool) ()
   from /usr/lib/kde3/libkwordpart.so
#9  0x414fbd6b in KWTextFrameSet::saveInternal(QDomElement&, bool, bool) ()
   from /usr/lib/kde3/libkwordpart.so
#10 0x415596f0 in KWTextFrameSet::save(QDomElement&, bool) ()
   from /usr/lib/kde3/libkwordpart.so
#11 0x414a35ce in KWDocument::saveXML() () from /usr/lib/kde3/libkwordpart.so
#12 0x4004cf85 in KoDocument::saveToStream(QIODevice*) ()
   from /usr/lib/libkofficecore.so.1
#13 0x4004cd4d in KoDocument::saveNativeFormat(QString const&) ()
   from /usr/lib/libkofficecore.so.1
#14 0x4004af2c in KoDocument::saveFile() () from /usr/lib/libkofficecore.so.1
#15 0x40165f67 in KParts::ReadWritePart::save() () from /usr/lib/libkparts.so.2
#16 0x4016626f in KParts::ReadWritePart::saveAs(KURL const&) ()
   from /usr/lib/libkparts.so.2
#17 0x4005a50a in KoMainWindow::saveDocument(bool) ()
   from /usr/lib/libkofficecore.so.1
#18 0x4005b3dd in KoMainWindow::slotFileSaveAs() ()
   from /usr/lib/libkofficecore.so.1
#19 0x4005e768 in KoMainWindow::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkofficecore.so.1
#20 0x409d751b in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x409d73ef in QObject::activate_signal(int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x404aabfb in KAction::activated() () from /usr/lib/libkdeui.so.4
#23 0x4049c24f in KAction::slotActivated() () from /usr/lib/libkdeui.so.4
#24 0x404aadef in KAction::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkdeui.so.4
#25 0x409d751b in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x40c7ced2 in QSignal::signal(QVariant const&) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x409f0078 in QSignal::activate() () from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0x40ab7406 in QPopupMenu::mouseReleaseEvent(QMouseEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x40a09b49 in QWidget::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x40988ce4 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0x40988442 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0x40683bc6 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#33 0x4093295b in QETWidget::translateMouseEvent(_XEvent const*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0x40930061 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x4092fbc6 in QApplication::processNextEvent(bool) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0x4098a2c0 in QApplication::enter_loop() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0x4092f5bd in QApplication::exec() () from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0x4001b0a1 in main () from /usr/lib/kword.so
#39 0x4106c108 in __libc_start_main () from /lib/i686/libc.so.6
Comment 1 Bill Nottingham 2002-03-28 03:54:53 EST
Does this persist in the current versions?
Comment 2 Tim Waugh 2002-04-02 03:58:06 EST
Couldn't reproduce it at the time; can't now either.
Comment 3 Tim Waugh 2004-07-22 04:14:28 EDT
NEEDINFO?  What info?  I think this can just be closed.
Comment 4 Ngo Than 2004-07-22 06:10:43 EDT
it's not reproduceable in FC1/FC2

Note You need to log in before you can comment on or make changes to this bug.