Bug 593573 - virt-manager cannot connect to remote hosts [nightly 20100518]
virt-manager cannot connect to remote hosts [nightly 20100518]
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 03:54 EDT by Christopher Curran
Modified: 2010-05-19 22:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-19 11:37:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Curran 2010-05-19 03:54:10 EDT
Description of problem:
virt-manager cannot connect to remote hosts presently. I've tried a RHEL5 KVM host and a Fedora 12 KVM host, both report the same error. There are no issues with the connection as virsh can connect to the hypervisor and issue commands.

Version-Release number of selected component (if applicable):
RHEL6-Client-20100518

How reproducible:
RHEL5.5 and Fedora 12 report errors.

Steps to Reproduce:
1. Open virt-manager
2. Select File->'Add Connection...'
3. input the details for the host
  
Actual results:
Python error:
Unable to open connection to hypervisor URI 'qemu+ssh://root@ccurran.bne.redhat.com/system':
cannot recv data: Resource temporarily unavailable
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 992, in _try_open
    None], flags)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 111, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: cannot recv data: Resource temporarily unavailable

Maybe you need to install ssh-askpass in order to authenticate.


Expected results:
connection works.

Additional info:
ssh-askpass is not available in RHEL6.
Comment 2 Cole Robinson 2010-05-19 11:37:06 EDT
SSH askpass looks like it was only added to the RHEL6 repos within the past couple days :)

I can see it here:

http://qafiler.bos.redhat.com/redhat/nightly/RHEL6.0-20100519.n.1/6/Server/x86_64/os/Packages/

but not here:

http://qafiler.bos.redhat.com/redhat/nightly/RHEL6.0-20100514.n.0/6/Server/x86_64/os/Packages/

(strangley http://qafiler.bos.redhat.com/redhat/nightly/latest-RHEL6.0/ points to the old tree).

Lack of askpass is the reason you are seeing that error, so closing as WORKSFORME.
Comment 3 Christopher Curran 2010-05-19 22:00:11 EDT
Works for me too now. Verified, this is fixed.

Note You need to log in before you can comment on or make changes to this bug.