Bug 59360 - missing TrueType font in fontmap
missing TrueType font in fontmap
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-print (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-06 09:20 EST by Akira TAGOH
Modified: 2013-01-10 16:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-11 01:09:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2002-02-06 09:20:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
TrueType entries need the printing for CJK. but gnome-font-install on %post is
not given those path.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install gnome-print
2.look at /etc/gnome/fonts/gnome-print-rpm.fontmap
3.
	

Actual Results:  'grep truetype /etc/gnome/fonts/gnome-print-rpm.fontmap ' is
nothing.

Expected Results:  should have several font entries.

Additional info:

You said on .spec, the font packages can't require gnome-print. but I don't
think it's good idea that this package always requires other font package. 
My solution is, gnome-print will give a script for updating fontmap, and calls
it from %post. if other font packages can find that script, also calls it. so
other font packages doesn't need to require gnome-print because it check whether
that script exists or not. 
And basically almost TrueType fonts is installed under /usr/share/fonts. if
updating script has that path with --recursive option, whichever font packages
and gnome-print is installed, fontmap should be updated as well.
Comment 1 Havoc Pennington 2002-02-25 21:24:28 EST
Your solution would mean that the font packages have to be installed after
gnome-print though, or stuff would break, and the installer doesn't make that
ordering guarantee does it?
Comment 2 Akira TAGOH 2002-02-25 21:49:12 EST
Why? for example the font packages has a script as the following on post:
if [ -x /usr/bin/update-gnome-font-install ]; then
  /usr/bin/update-gnome-font-install
fi

I assume update-gnome-font-install just calls gnome-font-install which has
needed options.even if gnome-print isn't installed yet, it just pass through
without stopping, and when gnome-print is installed, those fonts will be cared
by --recursive option of gnome-font-install. Is there any problem?
Comment 3 Leon Ho 2002-03-06 00:59:40 EST
Now most of our ttfonts* have this in our %post
if [ -x /usr/bin/update-gnome-font-install ]; then
  /usr/bin/update-gnome-font-install
fi

which will only run if /usr/bin/update-gnome-font-install exist. If the file
does not exist, that's mean gnome-print hasn't been install yet. Hence if we put
/usr/bin/update-gnome-font-install in gnome-print's %post too, then it will
reparse the fontmap no matter which order ttfonts* and gnome-print are getting
installed.

Please have a look gnome-print, ttfonts-* in 7.2-tcsc for reference.
Comment 4 Havoc Pennington 2002-03-08 16:23:23 EST
After "make install" in gnome-print, the build root doesn't contain a binary 
called update-gnome-font-install; where does that come from?
Comment 5 Leon Ho 2002-03-11 01:09:19 EST
In 7.2-tcsc, it is created through the spec file:
...
#Add update-gnome-font-install
cat > $RPM_BUILD_ROOT%{_bindir}/update-gnome-font-install << EOF
#!/bin/sh
/usr/bin/gnome-font-install                                             \
       --aliases=%{_datadir}/gnome-print/fonts/adobe-urw.font           \
       --target=%{_sysconfdir}/gnome/fonts/gnome-print-rpm.fontmap      \
       --recursive --clean                                              \
       /usr/X11R6/lib/X11/fonts/Type1                                   \
        %{_datadir}/fonts
EOF
chmod 755 $RPM_BUILD_ROOT%{_bindir}/update-gnome-font-install
...

Comment 6 Havoc Pennington 2002-03-13 17:52:02 EST
I added "redhat-update-gnome-font-install" in 0.35-2. I put redhat in the name
to make it clear that this is a Red Hat specific addition.

Note You need to log in before you can comment on or make changes to this bug.