Bug 593602 - Unable to upgrade system on md raid (installer doesn't see the array)
Summary: Unable to upgrade system on md raid (installer doesn't see the array)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-19 09:50 UTC by Leszek Matok
Modified: 2010-05-27 09:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-26 07:19:41 UTC
Type: ---


Attachments (Terms of Use)
console number 3 (IIRC) showing what appears to be failed downloads (243.25 KB, image/jpeg)
2010-05-22 19:03 UTC, Leszek Matok
no flags Details
anaconda.log (40 bytes, text/plain)
2010-05-25 12:31 UTC, Leszek Matok
no flags Details
program.log (39 bytes, text/plain)
2010-05-25 12:31 UTC, Leszek Matok
no flags Details
storage.log (39 bytes, text/plain)
2010-05-25 12:32 UTC, Leszek Matok
no flags Details
It sees my RAID after all... (44 bytes, text/plain)
2010-05-25 12:48 UTC, Leszek Matok
no flags Details
No upgrade option for me? (44 bytes, text/plain)
2010-05-25 13:02 UTC, Leszek Matok
no flags Details

Description Leszek Matok 2010-05-19 09:50:20 UTC
The title basically says it all.

I've run preupgrade. It frowned at /boot on md (why? It's mirrored, you can just access /dev/sda* just as /dev/md*, which GRUB does anyhow - if you can't detect md before stage2, just mount it read only and no md breakage will occur), but proposed to download stage2 later. Then there's this bug #592345 about additional spaces, which I've removed, leaving GRUB config as follows:
title Upgrade to Fedora 13 (Branch)
	kernel /boot/upgrade/vmlinuz preupgrade repo=hd::/var/cache/yum/preupgrade stage2=http://ftp.icm.edu.pl/pub/Linux/fedora/linux/development/13/i386/os/images/install.img
	initrd /boot/upgrade/initrd.img

It worked, stage2 took its time to download, but then I was greeted with a nice graphical installer. Nice, but:
- it insisted on formatting my drives (and was very clear about it) and didn't even show that there are file systems other than the "raid autodetect" ones,
- it didn't show my RAID device in appropriate tab (in the advanced view, that is).

So I went to console, typed in mdadm --assemble --scan and it created /dev/md127_0 device automatically with no problem at all (the name is weird, but nevermind).

Back in the installer, it suddenly started seeing the new manually assembled device, but as a hardware disk along the other 2, still telling me it will wipe out all the data on it. I went 3 or 4 screens deeper into the installation process to see if it will discover file systems, but got scared when it started asking me for things that made it more clear that I was attempting an installation, not an upgrade.

This system has been upgraded with yum for this very reason for 4 or more releases already. In fact, I'm running a yum update as we speak, using packages cached with preupgrade.

Basically I see three problems:
1. After all those years and even while claiming support for software RAID, it can't detect the simplest RAID of them all (which mdadm -A -s sees instantly).
2. Instead of telling me "there's no system to upgrade, do you want to install?", it just goes ahead and says "tell me which disks are for me" with the tiny letters below saying "I will clear 'em all"
3. Even though I do have file systems on partitions (plus the one on RAID disk, after I've assembled it manually), anaconda operates on disks... this screams for using a "WTF?!" Isn't there an option for multi-boot anymore?

This bug is for problem #1. #2 is minor and I'm sure you're getting enough whine for #3 if it's not a bug apeearing only on my system :)

Comment 1 Hans de Goede 2010-05-19 10:45:49 UTC
Can you please provide screenshots of what anaconda says when it "wants to format your drives" and preferably a lot more detailed description of what you are seeing.

Please provide:
-a step by step description of the steps successfully passed in the install 
 process (so that we know where you was when you got the unexpected message about
 formatting your drives)
-screenshots of the screen just before the error and the error
-attach all logs found under /tmp (/tmp/*log) at the time of the failure
 you can get these from tty2 (ctrl + alt + f2) and use for example scp to
 get them out of the installer environment.

Comment 2 Leszek Matok 2010-05-22 19:03:44 UTC
Created attachment 415885 [details]
console number 3 (IIRC) showing what appears to be failed downloads

Let's start from the beginning. I don't get any error whatsoever, it's just that the installer insists on _installing_ and not _upgrading_.

(TL;DR version at the very bottom)

Some of my confusion came from the fact that "Firmware RAID" is translated to "Software RAID" in Polish translation. It was obvious for me that my md raid should just be there because it's a software array. So if there's no option to upgrade, and at the same time I don't see the device on which my root file system is, I just came to the conclusion that it can't detect my system to upgrade and starts installation.

But then I started taking pictures for you using the installer in English and noticed what it was originally. It's "Firmware RAID", which I get are the motherboard fake arrays, pretending to be physical devices. My software RAID shouldn't be there after all. Polish translation FTL.

Then there's this really weird idea of asking me of what physical devices I want to use in my installation. Every one of the disks is a part of the array. They could also be parts of an LVM VG. I imagine having no idea which is which if they're all same size (or do you know your HDDs serial numbers?). So how can I decide which drives to use and which to not use?

Why even ask me this question about HDDs, then ask me 5 other question, then ask me the same question again (asks me to tell it which physical devices contain data and which don't? Come on, all of them can have data, even if there's free space on them / even if I want to format one partition on them) and again (third time it actually allows me to mount existing file systems if I click appropriate buttons first). I mean, WTF? OK, that's better, I just HAD to vent.

So apart of whining, I'm actually discovering how the installer wants to work, even if I will never believe that it was designed this way. So I think at last I know what I would click if I were to install on a new computer (provided I know the serial numbers, that is). But still, there is no option to upgrade the system. As already mentioned, I have many pictures of different screens, but I don't think they are required just now (keep on reading)..
_____

TL;DR: I think it just runs wrong image. See attached picture. Looks like it tries to download updates.img, then product.img and lastly install.img, which succeeds.

So does that mean I'm just running a wrong build of the installer?

Comment 3 Chris Lumens 2010-05-24 21:20:14 UTC
updates.img and product.img are optional files, and the failure to download them is pretty common.  They're only needed to apply modifications to anaconda at runtime.  As such, they have nothing to do with this bug.  Error or no, the log files asked for in comment #1 are still going to be necessary to fix this bug.

Comment 4 Hans de Goede 2010-05-25 11:31:57 UTC
Leslez,

Let me try to explain the new UI a bit, the first disk selection screen
is what we call the filter UI, normally one would select all disks in the system here (note it only shows disks, nothing else, no lvm, mdraid, etc).

This meant to be able to tell the installer to not look at a disk *at all*, this
includes not taking it into account for BIOS drive order (for grub), etc.

This is a feature mostly targeted at enterprise setups. For a normal installation even a somewhat advanced one. You should just select all disks at the first screen.

Have you tried selecting all disks there, and does your raid set then still not get seen? Note that not getting the option to upgrade is not necessarily the same
as your raid set not being seen. To verify the set is seen or not seen, proceed with the install and choose custom partitioning, then select all your disks again, now you end up in the storage editor, here you can see if we've recognized your raid sets or not. Note do not continue passed this point unless you want changes to be made to your disks.

Regards,

Hans

Comment 5 Leszek Matok 2010-05-25 12:31:26 UTC
Created attachment 416378 [details]
anaconda.log

Comment 6 Leszek Matok 2010-05-25 12:31:57 UTC
Created attachment 416379 [details]
program.log

Comment 7 Leszek Matok 2010-05-25 12:32:26 UTC
Created attachment 416380 [details]
storage.log

Comment 8 Leszek Matok 2010-05-25 12:48:52 UTC
Created attachment 416388 [details]
It sees my RAID after all...

Like I've mentioned earlier, I was confused by the fact that there is a "Software RAID" tab in the Polish translation and for me, it was obvious that I should simply see my md there. But in English version it's "Firmware RAID".

I've attached a picture which shows that it actually DOES see my array and this bug's title is completely wrong (plus all my original assumptions).

This image is from a try I did in Polish, the logs above were from the try I did in English.

So again, I'm really, really sorry for all the confusion, but on the other hand, it's not my fault that it's less user-friendly and badly translated than anything I've ever seen (BTW I actually was an Anaconda translator some time ago, but got tired fighting with people who speak worse Polish than I do English, my bad...)

Please hold on for just one more image before you claim NOTABUG...

Comment 9 Leszek Matok 2010-05-25 13:02:36 UTC
Created attachment 416396 [details]
No upgrade option for me?

I have some more nice screen shots, but this one is the main problem. There's no upgrade option.

As already mentioned, after selecting hard drives, it goes on to ask me for root password and host name. This already makes it a new installation and not an upgrade. Originally, I also took is as a proof that it really didn't discover my RAID.

But I've went through the screens and was greeted with the one on picture. It's English version again and there's no "upgrade existing system" anywhere.

This is also the session for which I've attached logs above.

So should there be an option to upgrade anywhere? Or maybe I need to create some custom layout with some special secret options and it will silently upgrade instead of installing over my system?

Comment 10 Leszek Matok 2010-05-25 13:05:39 UTC
I've just realised that "AttachURL" option attaches a text file with an URL in it :) I was expecting to either download the file and host a copy, or simply have an URL clickable :) Can't I do anything right lately? :(

Comment 11 Hans de Goede 2010-05-26 07:19:41 UTC
After the first disk selection screen, you will get the choice between upgrade or install *if* an upgradable product is found, otherwise we move directly into installation.

From the logs you've linked to:
17:42:33,667 INFO storage: product Fedora version 13 found on md127 is not upgradable

So you already have F-13 on there (perhaps an older version but still F-13), so indeed no upgrade for you. To upgrade from F-13 pre-releases to final you can simply do "yum update" from the running system.

Comment 12 Leszek Matok 2010-05-27 09:06:45 UTC
When I first started this bug, I had Fedora 12. Then proceeded with yum update and I now have Fedora 13. So _now_ it correctly detects a system that can't be upgraded, but still fails to tell me about it and I have to look into some hidden logs using obscure unix commands to know it? I've started my (to be) Fedora experience with RHL 4.1 actually and let me tell you the installer was never this unfriendly and illogical.

The original situation I can no longer reproduce myself [and I don't have any logs from the F12 upgrade tries :(], so I'm happy with your NOTABUG.

Which doesn't change the fact that back then it was F13 installer that couldn't upgrade F12. Just clearing that out, for future reference maybe.


Note You need to log in before you can comment on or make changes to this bug.