Bug 593608 - autorelabel will fail if selinux is upgraded
autorelabel will fail if selinux is upgraded
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 05:59 EDT by Matthew Booth
Modified: 2011-02-01 06:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-01 06:45:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2010-05-19 05:59:12 EDT
If a conversion upgrades SELinux, SELinux itself will be mislabelled. If the guest boots with SELinux in enforcing mode, autorelabel will fail because /lib/libselinux.so.1 cannot be read.

If the guest has SELinux in enforcing mode, we need to set it to permissive mode to do the relabel, and put it back afterwards, presumably in rc.local.
Comment 2 RHEL Product and Program Management 2010-12-07 05:34:51 EST
This request was evaluated by Red Hat Product Management for inclusion in Red Hat Enterprise Linux 5.6 and Red Hat does not plan to fix this issue the currently developed update.

Contact your manager or support representative in case you need to escalate this bug.
Comment 3 Rita Wu 2010-12-21 03:55:51 EST
Hi Matt,

How would I reproduce it? I cannot reproduce it via 2 senarios:
1. Convert a guest registered to rhn
2. Upgrade SELinux
Comment 5 RHEL Product and Program Management 2011-02-01 06:45:17 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.