Bug 59361 - GRUB fails to boot (partition table re-read problem)
GRUB fails to boot (partition table re-read problem)
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 59284 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-06 09:39 EST by Josep L. Guallar-Esteve
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-18 23:23:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josep Guallar-Esteve 2002-02-06 09:39:07 EST
* test tree re0205.1 
* test case i386/Spanish/Laptop/HTTP/TUI - Use PCMCIA
* test machine Dell Inspiron 3500 @ testlab


Description of Problem:

On first boot after install, the screen remains black with a blinking cursor and
the floppy drive light stays on. There's no trace of GRUB.


How Reproducible:

Always in this laptop


Steps to Reproduce:
1. Install testcase
2. reboot when finished
3. see the screen black and the floppy drive light on.

Actual Results:

3. see the screen black and the floppy drive light on.

Expected Results:

GRUB to appear
Comment 1 Josep Guallar-Esteve 2002-02-07 10:29:51 EST
Same problem with

* test tree re0206.6
Comment 2 Josep Guallar-Esteve 2002-02-07 11:26:39 EST
I just installed on the very same laptop:

* Red Hat Linux 7.2 Final
* i386/Spanish/Laptop/HTTP/TUI - Use PCMCIA

No problem at all.
Comment 3 Jeremy Katz 2002-02-22 18:39:54 EST
Not likely to be a high priority with the complete switch in direction for
Hampton, but by chance, do you remember if there were any partitions on the disk
when you went to do your 7.2 reinstall?  My guess is that it's related to the
"not rereading partition tables properly" problem, but having not seen it
myself, it's hard to say for sure.
Comment 4 Jeremy Katz 2002-02-22 18:40:45 EST
*** Bug 59284 has been marked as a duplicate of this bug. ***
Comment 5 Josep Guallar-Esteve 2002-02-25 12:14:53 EST
This laptop had the usual Linux partitions (ext3, swap) generated by a previos
install of  Red Hat beta. Like all the previous installs on a laptop.

If you need more info, let me know.

Also, you are welcome to change priority/severity. By high severity I was
pointing out that  I boot was not possible, which is a bad thing to happen.
Comment 6 Jeremy Katz 2002-02-25 12:36:25 EST
Hmm... so you just reused the existing partitions?  *shrug*  I'm sure it's
related to either the weirdness of partitioning or something I broke in the
bootloader code there.  Marking as needing to be fixed for the first beta of the
post-Hampton release for now unless we start seeing it with the new Hampton trees.
Comment 7 Josep Guallar-Esteve 2002-02-25 15:50:41 EST
I *did not* reuse existing partitions. 

I *did* select "delete all existing partitions on disk" when presented with
DiskDruid Wizard. The Laptop's harddisk held a previous release of RedHat Linux
beta.
Comment 8 Jeremy Katz 2002-02-25 16:19:15 EST
Aha, yep.  That's definitely one of the ways to hit the partition table not
being reread.  Fixed post-beta1.  Thanks for the clarification
Comment 9 Jay Turner 2002-03-07 11:07:56 EST
No longer seeing the partition table re-read problems.  Closing out.
Comment 10 Mike McLean 2002-06-04 16:02:04 EDT
I'm seeing this (or rather bug#59284) intermittently with the latest Milan trees.
Comment 11 Mike McLean 2002-06-11 16:43:47 EDT
I'm seeing this *every time* with the last few trees on a certain machine:  a
Compaq Proliant ML330e with an ide hard drive (ServerWorks OSB4 IDE controller).
Comment 12 Michael Fulbright 2002-07-17 11:52:37 EDT
Has this been a problem lately?
Comment 13 Josep L. Guallar-Esteve 2002-07-17 12:00:27 EDT
I've seen this with test tree 0712.nightly or test tree re0716.nightly .

* test case i386/Italian or Spanish/HTTP/Minimal or Workstation/TUI/Use PCMCIA
Comment 14 Jeremy Katz 2002-07-18 23:22:55 EDT
Fixed in CVS
Comment 15 Mike McLean 2002-07-25 16:15:10 EDT
The machine at my desk that had this problem not longer does.
Closing.

Note You need to log in before you can comment on or make changes to this bug.