Bug 593646 - Library lacks ability to receive multi-line input from user.
Summary: Library lacks ability to receive multi-line input from user.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: newt
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-19 11:55 UTC by Dmitry Mishin
Modified: 2010-11-10 17:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 17:40:25 UTC
Type: ---


Attachments (Terms of Use)
patch with widget (24.05 KB, patch)
2010-05-19 11:55 UTC, Dmitry Mishin
no flags Details | Diff

Description Dmitry Mishin 2010-05-19 11:55:21 UTC
Created attachment 415092 [details]
patch with widget

Description of problem:
Library lacks ability to receive multi-line input from user. It will be good to enhance it and create new newtMEntry widget for this purpose.

Version-Release number of selected component (if applicable):
0.52.11


P.S. Sorry, I understand that this is not a bug, but I didn't find newt development mailing list :(

Comment 1 Bug Zapper 2010-07-30 11:39:45 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Miroslav Lichvar 2010-08-04 16:15:37 UTC
There is no newt development list, filing bugs against Fedora newt package is fine.

I'm not sure how useful is this patch. From a multi-line entry I'd expect it to be scrolling only vertically with wrapping at a fixed width. I'd keep only one buffer for whole entry, add vertical scrolling and wrap lines that are longer that the entry width.

If it should be something similar to the GTK Text widget, adding support for editing to the textbox widget might be a better idea.

In any case, the patch would definitely need more work before accepting, the test example segfaulted for me when trying to add a fifth line in the entry and there were read errors reported by valgrind when scrolling horizontally on the first line. Also, the movement with arrow keys in the entry and around widgets doesn't work very well.

Comment 3 Dmitry Mishin 2010-11-10 17:40:25 UTC
Miroslav, thank you for your comments - appreciated.
I'll rewrite patch some time later and post new "bug" than. This one is CLOSED.


Note You need to log in before you can comment on or make changes to this bug.