Bug 593671 - CryptoError: luks_close failed for luks-bbd18ebf-7ee3-4745-b90d-1de8b6a7d48c
Summary: CryptoError: luks_close failed for luks-bbd18ebf-7ee3-4745-b90d-1de8b6a7d48c
Keywords:
Status: CLOSED DUPLICATE of bug 593487
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: anaconda_trace_hash:bbb29a5d0333decf9...
Depends On:
Blocks: 582286
TreeView+ depends on / blocked
 
Reported: 2010-05-19 13:20 UTC by Alexander Todorov
Modified: 2010-05-19 18:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-19 18:33:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (131.51 KB, text/plain)
2010-05-19 13:20 UTC, Alexander Todorov
no flags Details

Description Alexander Todorov 2010-05-19 13:20:33 UTC
The following was filed automatically by anaconda:
anaconda 13.21.39 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/crypto.py", line 120, in luks_close
    raise CryptoError("luks_close failed for %s" % name)
  File "/usr/lib/anaconda/storage/formats/luks.py", line 182, in teardown
    crypto.luks_close(self.mapName)
  File "/usr/lib/anaconda/storage/devices.py", line 1667, in teardown
    self.slave.originalFormat.teardown()
  File "/usr/lib/anaconda/storage/__init__.py", line 1293, in findExistingRootDevices
    device.teardown(recursive=True)
  File "/usr/lib/anaconda/upgrade.py", line 94, in findExistingRoots
    rootparts = findExistingRootDevices(anaconda, upgradeany=upgradeany)
  File "/usr/lib/anaconda/upgrade.py", line 81, in findRootParts
    flags.cmdline.has_key("upgradeany"))
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1348, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1261, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 1398, in keyRelease
    self.nextClicked()
CryptoError: luks_close failed for luks-bbd18ebf-7ee3-4745-b90d-1de8b6a7d48c

Comment 1 Alexander Todorov 2010-05-19 13:20:37 UTC
Created attachment 415103 [details]
Attached traceback automatically from anaconda.

Comment 3 Alexander Todorov 2010-05-19 13:25:02 UTC
This is on KVM domU with virtio. 

On the first install I had:
/dev/vda1 - boot, ext4
/dev/vda2 - PV, encrypted
lv_root, lv_swap - also encrypted 

Using the same pass phrase for all encrypted devices. The system was able to boot. 

Then started a second install on this guest. 
1) Anaconda detected that /dev/vda2 was encrypted and asked me for password. I've entered it without checking "Global pass-phrase"
2) Then it asked me for password for lv_root and I entered the same pass phrase and checked "Global passphrase"

Then the traceback happened.

Comment 4 Alexander Todorov 2010-05-19 13:29:02 UTC
Bug happens also if I select "Global passphrase" on the first ever dialog as well.

Comment 5 Bill Nottingham 2010-05-19 18:33:18 UTC

*** This bug has been marked as a duplicate of bug 593487 ***


Note You need to log in before you can comment on or make changes to this bug.