Bug 59369 - Faked bootp record has misleading ESA
Summary: Faked bootp record has misleading ESA
Status: CLOSED CURRENTRELEASE
Alias: None
Product: eCos
Classification: Retired
Component: TCPIP   
(Show other bugs)
Version: CVS
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: eCos bugs internal list
QA Contact: eCos bugs internal list
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-06 16:11 UTC by Jonathan Larmour
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 16:11:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Larmour 2002-02-06 16:11:14 UTC
Description of Problem:

In network_support.c: build_bootp_record() (used when using static addrs, NOT
bootp/dhcp) contains:

    for (i = 0;  i < bp->bp_hlen;  i++) {
        bp->bp_chaddr[i] = 0xFF;
    }

which has confused people because it causes the displayed ESA address (displayed
by show_bootp) to be all Fs, which worries some people. Instead it should fetch
the real ESA using ioctl(s, SIOCGIFHWADDR, &ifr) like in
boot_support.c:do_bootp()


Note You need to log in before you can comment on or make changes to this bug.