Bug 59374 - 3rd button mouse support lost under RH7.2 on Dell Latitude CPx500
3rd button mouse support lost under RH7.2 on Dell Latitude CPx500
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-06 12:18 EST by Michael Evans
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Evans 2002-02-06 12:18:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-21 i686)

Description of problem:
I recently upgraded to RH7.2 from RH7.0, and have updated all components via RH
update agent as of yesterday.  Now the third (middle) mouse button support is
lost. 
I used to be able to press both trackpad buttons and get the 3rd (middle) button
(used for pasting on a command line, for example).  Now I can't.

Here is current mouseconfig entry from /etc/X11/XF86Config-4:

Section "InputDevice"
	Identifier	"Mouse0"
	# Modified by mouseconfig
	Driver	"mouse"
	Option	"Device"		"/dev/mouse"
	Option	"Protocol"	"PS/2"
	Option	"Emulate3Buttons"	"yes"
	Option	ZAxismapping"	"4 5"
EndSection

I get copy and paste in emacs but need to use control-y now instead of just the
third mouse button.

I can't get copy and paste when X is not running either.

I tried copying back my /etc/X11/XF86Config-4 file from my RH7.0 installation,
from an archived copy of my /etc directory: no luck.  That configuration reads:

more /etc/X11/XF86Config-4

Section "InputDevice"
	Identifier	"Mouse0"
	Driver	"mouse"
	Option	"Protocol"	"PS/2"
	Option	"Device"		"/dev/psaux"
	Option	ZAxismapping"	"4 5"
	Option	"Emulate3Buttons"	"yes"
EndSection

As suggested by RH support I also tried rerunning mouseconfig repeatedly: no
luck.


Version-Release number of selected component (if applicable):
mouseconfig-4.23-1

How reproducible:
Didn't try (would require reinstalling RH7.0, then installing RH7.2...?)

Steps to Reproduce:
1. Upgrade to RH7.2 from RH 7.0 on a Dell Latitude CPx500 using RH CDs.
2. Configure as under RH7.0.
3. Install all recommended package updates to RH7.2.


Actual Results:  see Description.

Expected Results:  I was hoping to have third button support as before...

Additional info:

Here are versions of possible elements of the bug:

kernel vmlinuz-2.4.9-21
mouseconfig-4.23-1
XFree86-4.1.0-15
Xconfigurator-4.9.39-2

Thanks for any help on this.
Comment 1 Brent Fox 2002-10-10 14:16:22 EDT
I have just completed a text mode interface for redhat-config-mouse, which means
that mouseconfig will be deprecated in the next release of Red Hat Linux.  

Therefore, I will not be putting any development time towards fixing mouseconfig
bugs, so I'm closing this as 'wontfix'.
Comment 2 Red Hat Bugzilla 2006-02-21 13:48:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.