Bug 59375 - Settings menu selection on docked appicons crashes WindowMaker-0.80.1-1
Summary: Settings menu selection on docked appicons crashes WindowMaker-0.80.1-1
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: WindowMaker   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-06 17:38 UTC by Habig, Alec
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 19:01:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Habig, Alec 2002-02-06 17:38:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205

Description of problem:
If one right clicks on a docked or clipped appicon and chooses "settings",
WindowMaker crashes.  It does catch itself and let you restart without dropping
back out of X, though, which is a nice feature.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Right click on a docked appicon
2.select "settings"
3.watch WindowMaker die
	

Actual Results:  WindowMaker dies.  Don't see a core file and am not sure where
WM logs errors.


Expected Results:  You should enter a window where one can change properties of
the application in question.

Additional info:

Found this while trying to see where the "wmclock" applet had gotten to - this
appears to have been left out of the 0.80-1 rpm (worth a seperate bug entry?)

Am running on a fully updated 7.2 system, so had to rebuild from the SRPM due to
gcc 3 dependancy of the binary.

Comment 1 Phil Copeland 2002-02-06 19:01:07 UTC
Ok I can confirm this is the case... investigating


Comment 2 Phil Copeland 2002-02-06 19:27:54 UTC
Ok, this looks to be a bug in the XIM patch that flakes out. I'm reverting the
patch.
If you happen to have the srpm kicking about edit the spec file and hash out the
%Patch1 line and the --enable-xim line.

Kicking this upstream to let the XIM patch person ponder over whats gone wrong.

The patch that is applied if off
	http://www.sh.rim.or.jp/~ssato/wm-i18n/index-e.html
but is based on one at

http://www.on.cs.keio.ac.jp/~yasu/linux/WindowMaker/WindowMaker-0.62.1-WINGs_im.patch

If someone can correct the fault and pass me over the patch I'll happily
reinclude it in the distribution

Please note: Time is short for patchs to work their way through (<2 weeks)

Cheers

Phil
=--=

Comment 3 Phil Copeland 2002-02-19 22:18:22 UTC
Updated patch reintergated with 0.80.0-6, wait for rawhide to pick that up
tonight

Phil
=--=


Note You need to log in before you can comment on or make changes to this bug.