Bug 593754 - PartitionException: Extended partitions cannot be hidden on msdos disk labels.
PartitionException: Extended partitions cannot be hidden on msdos disk labels.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Hans de Goede
Release Test Team
anaconda_trace_hash:dfacaa53651c4bd0f...
:
Depends On:
Blocks: 582286
  Show dependency treegraph
 
Reported: 2010-05-19 12:08 EDT by Alexander Todorov
Modified: 2010-07-02 16:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: anaconda-13.21.50-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 16:49:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (281.04 KB, text/plain)
2010-05-19 12:09 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2010-05-19 12:08:56 EDT
The following was filed automatically by anaconda:
anaconda 13.21.39 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/partition.py", line 161, in unsetFlag
    return self.__partition.set_flag(flag, 0)
  File "/usr/lib64/python2.6/site-packages/parted/decorators.py", line 31, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in unsetFlag
  File "/usr/lib/anaconda/storage/devices.py", line 1232, in unsetFlag
    self.partedPartition.unsetFlag(flag)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 276, in execute
    self.device.unsetFlag(flag)
  File "/usr/lib/anaconda/storage/devicetree.py", line 693, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 292, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1260, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1398, in keyRelease
    self.nextClicked()
PartitionException: Extended partitions cannot be hidden on msdos disk labels.
Comment 1 Alexander Todorov 2010-05-19 12:09:02 EDT
Created attachment 415183 [details]
Attached traceback automatically from anaconda.
Comment 2 Alexander Todorov 2010-05-19 12:13:06 EDT
I've created the following disk layout:

/dev/vda1 - /boot, ext4
/dev/vda2 - swap
/dev/vda3 - /home, ext4
/dev/vda4 - extended
  /dev/vda5 - /, ext4

Then selected the extended partition and clicked Edit. It was showing fstype: ext4, size 1. I've changed the fstype to xfs, pressed OK and continued to write changes on disk. Then anaconda spew this traceback.

Should the user be able to edit an extended partition? (I think not).
Comment 3 Hans de Goede 2010-05-20 11:02:45 EDT
Hi,

Thanks for the report, and thanks for the hint that this is caused by editing extended partitions indeed that should not be allowed.

Regards,

Hans
Comment 4 Hans de Goede 2010-05-20 11:05:24 EDT
Dave,

I see that you've taken this one, I've just send a patch for that to the list, I've even tested it :)

I guess I should have taken this bug before started working on it.

Regards,

Hans
Comment 5 Hans de Goede 2010-05-31 08:51:58 EDT
This is fixed in anaconda-13.21.50-1, moving to modified.
Comment 7 Alexander Todorov 2010-06-29 06:33:32 EDT
with anaconda-13.21.50-9 it's not possible to edit the extended partition. Moving to VERIFIED.
Comment 8 releng-rhel@redhat.com 2010-07-02 16:49:50 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.