Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 593772 - [abrt] crash in libgsf-gnome-1.14.15-4.fc12: ole_dirent_new: Process /usr/bin/gsf-office-thumbnailer was killed by signal 7 (SIGBUS)
[abrt] crash in libgsf-gnome-1.14.15-4.fc12: ole_dirent_new: Process /usr/bin...
Status: CLOSED DUPLICATE of bug 616831
Product: Fedora
Classification: Fedora
Component: libgsf (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:7ac4d729597e73b7d87b48f455c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 12:53 EDT by yam
Modified: 2010-09-05 11:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-20 07:41:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (22.06 KB, text/plain)
2010-05-19 12:53 EDT, yam
no flags Details

  None (edit)
Description yam 2010-05-19 12:53:52 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: gsf-office-thumbnailer -i '/media/\x1e2/other people\'s stuff/ruta_vazdike_cv.doc' -o /tmp/.gnome_desktop_thumbnail.WZU6CV -s 128
component: libgsf
crash_function: ole_dirent_new
executable: /usr/bin/gsf-office-thumbnailer
global_uuid: 7ac4d729597e73b7d87b48f455cf53af72a5dbce
kernel: 2.6.32.11-99.fc12.i686
package: libgsf-gnome-1.14.15-4.fc12
rating: 4
reason: Process /usr/bin/gsf-office-thumbnailer was killed by signal 7 (SIGBUS)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. copy to usb stick is highly error-prone 
2. Lots of faulty files
3. This crash came in the midst of an attempt to recopy a faulty file, replacing a corrupt one on the USB stick
Comment 1 yam 2010-05-19 12:53:56 EDT
Created attachment 415191 [details]
File: backtrace
Comment 2 Caolan McNamara 2010-05-19 14:34:30 EDT
Do you still have the ruta_vazdike_cv.doc which made it crash ? If so can you attach it here, or send it to me privately. That would make it easy to fix.
Comment 3 yam 2010-05-19 15:21:20 EDT
I do still have the file, but I cannot share it, since it is the personal CV of someone who was using my computer.
I was moving a lot of data, however, and I was getting very frequent write errors when copying the data to the USB stick, especially with larger audio and video files. Reformatting the USB stick as ext3 eliminated the errors, but slowed down the process to a crawl.
Comment 4 Caolan McNamara 2010-05-20 07:41:29 EDT
As you say, with all those read and write errors its likely that it was a nigh unavoidable situation with an underlying unreliable file system.
Comment 5 Caolan McNamara 2010-09-05 11:27:07 EDT

*** This bug has been marked as a duplicate of bug 616831 ***

Note You need to log in before you can comment on or make changes to this bug.