Bug 593786 - repoquery does not check whether a repo id supplied with --repoid exists
Summary: repoquery does not check whether a repo id supplied with --repoid exists
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
(Show other bugs)
Version: 12
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-19 17:15 UTC by Till Maas
Modified: 2014-01-21 23:15 UTC (History)
5 users (show)

Fixed In Version: yum-utils-1.1.27-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-20 19:38:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Till Maas 2010-05-19 17:15:22 UTC
Description of problem:
I just used a wrong repoquery without noticing:
repoquery --repoid=fedora-updates --repoid=fedora  --releasever 13 youtube-dl

The problem is, the that there is no repo with the id fedora-updates, it is just updates. Nevertheless repoquery did not tell me this.


Version-Release number of selected component (if applicable):
yum-utils-1.1.26-1.fc12


How reproducible:

always

Steps to Reproduce:
1. repoquery --repoid=INVALID-$RANDOM  yum-utils
  
Actual results:
returns nothing

Expected results:
should tell that there is no such repo.

Additional info:

Comment 1 James Antill 2010-05-20 19:38:57 UTC
I added this upstream, however there is a long tradition of:

. repoquery doesn't output anything to stderr in non-quiet mode.

. repoquery is in quiet mode by default.

...but:

repoquery --verbose --repoid=alkfjaljf -a

...will now tell you what you did wrong.

Comment 2 Till Maas 2010-05-20 20:20:52 UTC
(In reply to comment #1)
> I added this upstream, however there is a long tradition of:
> 
> . repoquery doesn't output anything to stderr in non-quiet mode.

Here are two mistakes I already made when I used repoquery (obviously with other parameters) regarding repo selection, where repoquery wrote something to stderr (the first one might be unintended):

$ repoquery --repofrompath=/dev/null foo
Traceback (most recent call last):
  File "/usr/bin/repoquery", line 867, in <module>
    main(sys.argv)
  File "/usr/bin/repoquery", line 784, in main
    repoid,repopath = tuple(repo.split(','))
ValueError: need more than 1 value to unpack

$ repoquery --repofrompath=blah,/dev/null foo
Cannot retrieve repository metadata (repomd.xml) for repository: blah. Please verify its path and try again

Comment 3 James Antill 2010-05-21 14:05:39 UTC
Hmm, apparently errors do come out in quiet mode (I've fixed the description of quiet). So I change the repoquery error message to come out too.

The former was a bug, and has been fixed.

Comment 4 Fedora Update System 2010-06-06 13:44:28 UTC
yum-utils-1.1.27-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/yum-utils-1.1.27-1.fc13

Comment 5 Fedora Update System 2010-06-14 17:19:54 UTC
yum-utils-1.1.27-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.