Bug 59380 - updfstab and PAM fail to set user perms for zip in RH7.1
Summary: updfstab and PAM fail to set user perms for zip in RH7.1
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-06 18:22 UTC by Paul Raines
Modified: 2014-03-17 02:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 22:44:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Raines 2002-02-06 18:22:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; T312461)

Description of problem:
The problem is that when a user plugs in
a USB zip drive, the fstab gets updated but the device does not
get the perms that will let them mount it.  The console.perms
only has /mnt/zip* in it for the <zip> class.  Curiously, the
/mnt/zip* directory don't get perm changes anyway.  I know
previously <zip> used to have /dev/zip* in it and kudzu used
to make /dev/zip* links to the real devices. I guess updfstab
needs to be fixed to make those links and /dev/zip* needs to
be put back in console.apps.

Also, zip's seems to come in two formats.  In one format,
you mount partition 4 (e.g. /dev/sda4).  In another, you have
to mount the whole disk (e.g. /dev/sda).  It would be nice if
updfstab handled both these using something like /mnt/zipalt100.0
for the whole disk device.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attach a USB zip drive
2. Put a zip in drive
3. Try to mount as the normal user logged into console
	

Actual Results:  User did not have permission to mount drive

Expected Results:  User should be able to mount drive

Additional info:

Comment 1 Bill Nottingham 2005-02-04 22:44:05 UTC
Closing out bugs on older, no longer supported releases. Apologies for any lack
of response. Please attempt to confirm with more recent releases.


Note You need to log in before you can comment on or make changes to this bug.