This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 593824 - fcoe-utils should be upgraded to 1.0.14
fcoe-utils should be upgraded to 1.0.14
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fcoe-utils (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Jan Zeleny
Miroslav Vadkerti
: OtherQA, Rebase
Depends On: 593827
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 15:19 EDT by Yi Zou
Modified: 2010-11-15 08:57 EST (History)
2 users (show)

See Also:
Fixed In Version: fcoe-utils-1.0.14-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 08:57:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Man page patches tar ball with patch series file included (5.06 KB, application/x-gzip-compressed)
2010-06-11 14:09 EDT, Yi Zou
no flags Details

  None (edit)
Description Yi Zou 2010-05-19 15:19:39 EDT
Please pull latest fcoe-utils from Open-FCoE.org:

Git Repo: git://www.open-fcoe.org/openfc/fcoe-utils.git
Branch: master
Tag: v1.0.14
Log: http://www.open-fc.org/openfc/gitweb/?p=openfc/fcoe-utils.git;a=shortlog
List of patches:
> git log --pretty=oneline --abbrev-commit v1.0.13..v1.0.14
f470438 fcoe-utils: Increment fcoe-utils version from 1.0.13 to 1.0.14
ac5fafe QUICKSTART: Update for lldpad
b545c9a fcoedump.sh: Update for lldpad
c8eaf4a fcoe-utils: use SAN MAC if available for FIP VLAN Request in lib/fip
35a5b4e fcoe-utils: add getting SAN MAC via dcbnl interface to lib/rtnetlink
a834db0 fcoe-utils: correct spelling error in man pages
04aa7a6 fipvlan: don't add FIP socket to poll list if interface is down
65a8ecf fipvlan: CAP_NET_RAW capability check
f204823 fcoemon: saner behavior when mixing VLAN discovery and fcoeadm commands
aa45138 fcoeadm: don't check so much before sending a command to fcoemon
80287ee fcoeadm: remove check for running fcoemon
225e81b fcoe-utils: fix broken error logging (no decode of errno)
9460893 fcoe-utils: fix swapped defines for ALL_FCF_MACS and ALL_ENODE_MACS
759be4c fcoemon: behavior of auto VLAN interfaces on link events
bbd86b9 fcoemon: disable interface on DCB error, without waiting for retry
10b19b3 fcoe-utils: make a clear error log message to indicate failure reason
6bb20e0 fcoe-utils: replace "dcbd" with "lldpad" in log message
24e48a7 fcoe-utils: fix fcoemon syslog command line option
40401a5 fcoe-utils: fixes no lun display issue due to wrong check for target role
3c8fd80 fcoemon: use a separate packet socket per-interface for vlan discovery
8da534b fipvlan: use a seperate packet socket for each interface
5487b59 fcoemon: use daemon(3)
34e8d2c fcoe-utils: fix VLAN discovery when the interface is also part of a bond

Notes:
1) Libhbalinux also needs updating, I will create a separate BZ for it shortly after this.
2) A new version of lldpad is also around the corner. As soon as it gets out to sourceforge, I will create a BZ as a request to pull.
Comment 2 Yi Zou 2010-05-19 15:26:54 EDT
(In reply to comment #0)
> Notes:
> 1) Libhbalinux also needs updating, I will create a separate BZ for it shortly
> after this.
Bug 593827 has been created for libhbalinux.
Comment 3 RHEL Product and Program Management 2010-05-20 04:25:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Jan Zeleny 2010-05-21 03:11:44 EDT
I'm waiting for approval of this rebase right now. In the meantime I was advised of missing man pages in fcoe-utils. Particularly for these utilities:

/usr/sbin/fcnsq
/usr/sbin/fcping
/usr/sbin/fcrls

Every utility in RHEL-6 should have its man page. Could you guys please make them? I'll probably have to create them anyway, but I prefer you making them because this way they'll most likely be more precise. What do you think?
Comment 5 Yi Zou 2010-05-21 13:19:11 EDT
(In reply to comment #4)
> I'm waiting for approval of this rebase right now. In the meantime I was
> advised of missing man pages in fcoe-utils. Particularly for these utilities:
> 
> /usr/sbin/fcnsq
> /usr/sbin/fcping
> /usr/sbin/fcrls
> 
> Every utility in RHEL-6 should have its man page. Could you guys please make
> them? I'll probably have to create them anyway, but I prefer you making them
> because this way they'll most likely be more precise. What do you think?    

This would not block you getting your rpm updated, right? Meanwhile I will get man pages creation started for these tools, and post to open-fcoe.org later, then you can also review.
Comment 6 Jan Zeleny 2010-05-24 02:51:29 EDT
No, it's not a blocker for now. But I think it will be an issue later. I will prepare new packages and those man pages can be added afterwards.
Comment 7 Jan Zeleny 2010-05-24 05:06:47 EDT
The build is ready, switching to MODIFIED.
Comment 9 Yi Zou 2010-06-11 14:09:54 EDT
Created attachment 423358 [details]
Man page patches tar ball with patch series file included

This tar ball is to address Bug 593824 and Bug 594173. It includes the following patches that are sent to open-fcoe.org and expected to be pulled in to fcoe-utils.git soon.

eada1dc fcoe-utils/fcping: add man page for the fcping tool
45c5d35 fcoe-utils/fcnsq: add man page for the fcnsq tool
d955332 fcoe-utils/fcrls: add man page for the fcrls tool
54d5e2b fcoe-utils/fcrls: rport in sysfs can be a link as well

Links to the patch on mailing list:
http://www.open-fcoe.org/pipermail/devel/2010-June/010350.html
http://www.open-fcoe.org/pipermail/devel/2010-June/010349.html
http://www.open-fcoe.org/pipermail/devel/2010-June/010351.html
http://www.open-fcoe.org/pipermail/devel/2010-June/010352.html


Links to open-fcoe.org patch work if you want to get then from there
http://www.open-fcoe.org/patchwork/project/open-fcoe/list/
Comment 12 releng-rhel@redhat.com 2010-11-15 08:57:29 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.