Bug 593863 - Cobbler kickstart failure with special characters in organisation name
Summary: Cobbler kickstart failure with special characters in organisation name
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning   
(Show other bugs)
Version: 530
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2010-05-19 21:42 UTC by Rhys Oxenham
Modified: 2010-07-13 04:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 04:10:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rhys Oxenham 2010-05-19 21:42:05 UTC
Description of problem:
When the organisation name contains special characters, e.g. 'Example, Inc.' it causes cobbler to fail upon creating a kickstart file.

When Cobbler creates the kickstart name, e.g. 1:servers:Red-Hat, it replaces spaces with '-', yet it doesn't seem to be able to manage special characters such as ',' and '.'. If this is the case then customers/users should not be able to input these into the organisation name, they should also never appear in Satellite Certificates.

Version-Release number of selected component (if applicable):
RHN Satellite 5.3.0 Embedded-Database
RHEL 5.4

How reproducible:
Every time for me on RHN Satellite 5.3.0. 

Steps to Reproduce:
1. Create an Organisation with a name that contains special characters, e.g. ','
2. Login as an Organisation Admin or a user that can create kickstarts
3. Attempt to create a kickstart file for this organisation
  
Actual results:
'Internal Server Error'
The server is unable to create the kickstart file, there's no evidence of anything in the Satellite UI, it's not partially created at all. 

Expected results:
Kickstart created based on the organisation, either Satellite or Cobbler needs to be able to parse organisation names with special characters or not allow them to be entered at all. 

Additional info:
If the organisation is renamed (even with software/configuration channels assigned) to one without the special characters, e.g. from our previous example 'Example Inc', kickstarts are able to be made straight away.

Log files do show that there's an error in the name (/var/log/tomcat5/catalina.out)

Comment 1 Justin Sherrill 2010-05-19 22:37:26 UTC
What version of spacewalk-java is installed on this satellite? 

This should have already been fixed (just need to yum update spacewalk-java).

-Justin

Comment 2 Rhys Oxenham 2010-05-20 08:30:50 UTC
Hi Justin,

spacewalk-java wasn't even installed on the Satellite! I did a 'yum install' and it provided me with: spacewalk-java.noarch 0:0.5.44-51.el5sat

The exact error message we're getting in the Catalina log file is as follows:

redstone.xmlrpc.XmlRpcFault: cobbler.cexceptions.CX:'invalid characters in name'

Comment 3 Clifford Perry 2010-06-02 17:14:34 UTC
Please open a support ticket for this. Right now we feel this is not a bug and most likely Red Hat Support will be able to confirm cause and resolution.

Cliff

Comment 4 Rhys Oxenham 2010-06-03 07:27:58 UTC
Thanks Cliff, I've been advised that this has actually been resolved in spacewalk-java. 

You may close the ticket.


Note You need to log in before you can comment on or make changes to this bug.