Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 593868 - SELinux is preventing /usr/sbin/httpd from using potentially mislabeled files ZendDiskStorageDir.
SELinux is preventing /usr/sbin/httpd from using potentially mislabeled files...
Status: CLOSED DUPLICATE of bug 593866
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:dd9aeafa19d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 17:54 EDT by Clement
Modified: 2010-05-20 07:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-20 07:02:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clement 2010-05-19 17:54:43 EDT
Summary:

SELinux is preventing /usr/sbin/httpd from using potentially mislabeled files
ZendDiskStorageDir.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux has denied the httpd access to potentially mislabeled files
ZendDiskStorageDir. This means that SELinux will not allow httpd to use these
files. If httpd should be allowed this access to these files you should change
the file context to one of the following types, httpd_var_lib_t,
httpd_var_run_t, var_lock_t, tmp_t, var_t, squirrelmail_spool_t,
httpd_rw_content, tmpfs_t, httpd_cache_t, httpd_tmpfs_t, httpdcontent,
var_lib_t, var_run_t, httpd_tmp_t, httpd_squirrelmail_t, var_log_t,
httpd_squid_content_ra_t, httpd_squid_content_rw_t,
httpd_apcupsd_cgi_content_ra_t, httpd_apcupsd_cgi_content_rw_t,
httpd_sys_content_t, httpd_prewikka_content_ra_t, httpd_prewikka_content_rw_t,
httpd_awstats_content_ra_t, httpd_awstats_content_rw_t,
httpd_w3c_validator_content_ra_t, httpd_w3c_validator_content_rw_t,
httpd_user_content_ra_t, httpd_user_content_rw_t, httpd_cobbler_content_ra_t,
httpd_cobbler_content_rw_t, httpdcontent, httpd_munin_content_ra_t,
httpd_munin_content_rw_t, root_t, httpd_bugzilla_content_ra_t,
httpd_bugzilla_content_rw_t, httpd_nagios_content_ra_t,
httpd_nagios_content_rw_t, httpd_sys_content_ra_t, httpd_sys_content_rw_t,
httpd_sys_content_rw_t, httpd_cvs_content_ra_t, httpd_cvs_content_rw_t,
httpd_git_content_ra_t, httpd_git_content_rw_t, httpd_nutups_cgi_content_ra_t,
httpd_nutups_cgi_content_rw_t. Many third party apps install html files in
directories that SELinux policy cannot predict. These directories have to be
labeled with a file context which httpd can access.

Allowing Access:

If you want to change the file context of ZendDiskStorageDir so that the httpd
daemon can access it, you need to execute it using semanage fcontext -a -t
FILE_TYPE 'ZendDiskStorageDir'.
where FILE_TYPE is one of the following: httpd_var_lib_t, httpd_var_run_t,
var_lock_t, tmp_t, var_t, squirrelmail_spool_t, httpd_rw_content, tmpfs_t,
httpd_cache_t, httpd_tmpfs_t, httpdcontent, var_lib_t, var_run_t, httpd_tmp_t,
httpd_squirrelmail_t, var_log_t, httpd_squid_content_ra_t,
httpd_squid_content_rw_t, httpd_apcupsd_cgi_content_ra_t,
httpd_apcupsd_cgi_content_rw_t, httpd_sys_content_t,
httpd_prewikka_content_ra_t, httpd_prewikka_content_rw_t,
httpd_awstats_content_ra_t, httpd_awstats_content_rw_t,
httpd_w3c_validator_content_ra_t, httpd_w3c_validator_content_rw_t,
httpd_user_content_ra_t, httpd_user_content_rw_t, httpd_cobbler_content_ra_t,
httpd_cobbler_content_rw_t, httpdcontent, httpd_munin_content_ra_t,
httpd_munin_content_rw_t, root_t, httpd_bugzilla_content_ra_t,
httpd_bugzilla_content_rw_t, httpd_nagios_content_ra_t,
httpd_nagios_content_rw_t, httpd_sys_content_ra_t, httpd_sys_content_rw_t,
httpd_sys_content_rw_t, httpd_cvs_content_ra_t, httpd_cvs_content_rw_t,
httpd_git_content_ra_t, httpd_git_content_rw_t, httpd_nutups_cgi_content_ra_t,
httpd_nutups_cgi_content_rw_t. You can look at the httpd_selinux man page for
additional information.

Additional Information:

Source Context                unconfined_u:system_r:httpd_t:s0
Target Context                unconfined_u:object_r:unlabeled_t:s0
Target Objects                ZendDiskStorageDir [ dir ]
Source                        httpd
Source Path                   /usr/sbin/httpd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           httpd-2.2.14-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-114.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   httpd_bad_labels
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.i686.PAE #1 SMP Mon Apr 5
                              16:15:03 EDT 2010 i686 i686
Alert Count                   3
First Seen                    Wed 19 May 2010 11:37:43 PM MYT
Last Seen                     Thu 20 May 2010 04:04:19 AM MYT
Local ID                      134561be-e48c-40bb-94ba-0c8323892b62
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274299459.628:44): avc:  denied  { read write } for  pid=3807 comm="httpd" name="ZendDiskStorageDir" dev=sda1 ino=657401 scontext=unconfined_u:system_r:httpd_t:s0 tcontext=unconfined_u:object_r:unlabeled_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1274299459.628:44): arch=40000003 syscall=33 success=yes exit=0 a0=b5189630 a1=6 a2=44a46f4 a3=44a52a0 items=0 ppid=1 pid=3807 auid=500 uid=0 gid=0 euid=48 suid=0 fsuid=48 egid=489 sgid=0 fsgid=489 tty=(none) ses=1 comm="httpd" exe="/usr/sbin/httpd" subj=unconfined_u:system_r:httpd_t:s0 key=(null)



Hash String generated from  httpd_bad_labels,httpd,httpd_t,unlabeled_t,dir,read,write
audit2allow suggests:

#============= httpd_t ==============
#!!!! The source type 'httpd_t' can write to a 'dir' of the following types:
# httpd_var_lib_t, httpd_var_run_t, var_lock_t, tmp_t, var_t, squirrelmail_spool_t, httpd_rw_content, tmpfs_t, httpd_cache_t, httpd_tmpfs_t, httpdcontent, var_lib_t, var_run_t, httpd_tmp_t, httpd_squirrelmail_t, var_log_t, httpd_squid_content_ra_t, httpd_squid_content_rw_t, httpd_apcupsd_cgi_content_ra_t, httpd_apcupsd_cgi_content_rw_t, httpd_sys_content_t, httpd_prewikka_content_ra_t, httpd_prewikka_content_rw_t, httpd_awstats_content_ra_t, httpd_awstats_content_rw_t, httpd_w3c_validator_content_ra_t, httpd_w3c_validator_content_rw_t, httpd_user_content_ra_t, httpd_user_content_rw_t, httpd_cobbler_content_ra_t, httpd_cobbler_content_rw_t, httpdcontent, httpd_munin_content_ra_t, httpd_munin_content_rw_t, root_t, httpd_bugzilla_content_ra_t, httpd_bugzilla_content_rw_t, httpd_nagios_content_ra_t, httpd_nagios_content_rw_t, httpd_sys_content_ra_t, httpd_sys_content_rw_t, httpd_sys_content_rw_t, httpd_cvs_content_ra_t, httpd_cvs_content_rw_t, httpd_git_content_ra_t, httpd_git_content_rw_t, httpd_nutups_cgi_content_ra_t, httpd_nutups_cgi_content_rw_t

allow httpd_t unlabeled_t:dir { read write };
Comment 1 Miroslav Grepl 2010-05-20 07:02:09 EDT

*** This bug has been marked as a duplicate of bug 593866 ***

Note You need to log in before you can comment on or make changes to this bug.