Bug 593871 - cannot activate VG with missing PV(s)
cannot activate VG with missing PV(s)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity urgent
: rc
: ---
Assigned To: Hans de Goede
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 18:02 EDT by Brian Lane
Modified: 2010-07-02 16:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.21.44-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 16:49:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback (215.22 KB, text/plain)
2010-05-19 18:02 EDT, Brian Lane
no flags Details

  None (edit)
Description Brian Lane 2010-05-19 18:02:24 EDT
Created attachment 415273 [details]
traceback

Description of problem:
Created an updates image with all changes since v13.21.39-1 and booted 20100512 Workstation DVD with the updates.

After formatting some of the partitions it fails with the error: cannot activate VG with missing PV(s)


How reproducible:
Always

I modified my updates.img to include only the test I was trying to test and it ran fine. If I create an updates with changes since 13.21.43 it has my changes for mount sanity and storage module changes, which fails. If I remove the storage changes, leaving only my changes since 13.21.43 it runs correctly.
Comment 2 Hans de Goede 2010-05-20 05:23:01 EDT
Oh, brown paper bag bug. I made 2 innocent looking changes to the patchset in question after some discussions with dlehman (but this is entirely my fault) and
I did not retest.

The exception which you are seeing used to get thrown based on this check:
if len(self.parents) < self.pvCount:

Which I changed to:
if not self.complete:

Which boils down to:
if len(self.parents) != self.pvCount:

But self.pvCount never gets set for non pre existing vgs, so it is always
0, we didn't trip over this before because of the (wrong) < check in the original code.

Patch coming up.

Note to PM and QA, this bug makes any installs involving lvm fail, can we get acks please.
Comment 3 Hans de Goede 2010-05-20 05:53:51 EDT
Fixed in anaconda-13.21.44-1, moving to modified.
Comment 4 Alexander Todorov 2010-05-20 05:55:04 EDT
The traceback is:

anaconda 13.21.39 exception report
Traceback (most recent call first):
  File "/tmp/updates/storage/devices.py", line 1930, in setup
    raise DeviceError("cannot activate VG with missing PV(s)", self.name)
  File "/tmp/updates/storage/devices.py", line 1969, in create
    self.setup()
  File "/tmp/updates/storage/deviceaction.py", line 203, in execute
    self.device.create(intf=intf)
  File "/tmp/updates/storage/devicetree.py", line 701, in processActions
    action.execute(intf=self.intf)
  File "/tmp/updates/storage/__init__.py", line 292, in doIt
    self.devicetree.processActions()
  File "/tmp/updates/packages.py", line 109, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/tmp/updates/gui.py", line 1423, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/tmp/updates/gui.py", line 1336, in nextClicked
    self.setScreen ()
DeviceError: ('cannot activate VG with missing PV(s)', 'VolGroup')
Comment 5 Brian Lane 2010-05-20 11:52:44 EDT
Perfect! This fixes the problem for me. I retested with the same setup, only difference was the updates included this morning's commits, and it works fine.
Comment 7 Alexander Todorov 2010-05-25 12:13:21 EDT
With snapshot #5 (0523.0) I did two installs:

1) Using defaults (LVM) with 2 disks
2) Using all space (LVM) with only the second disk

There was no error. Moving to VERIFIED.
Comment 8 releng-rhel@redhat.com 2010-07-02 16:49:52 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.