Bug 593887 - Terse validity error messages make troubleshooting XML structure issues difficult.
Terse validity error messages make troubleshooting XML structure issues diffi...
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 20:01 EDT by Jared MORGAN
Modified: 2015-08-09 21:21 EDT (History)
5 users (show)

See Also:
Fixed In Version: publican-2.1-0.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 13:36:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jared MORGAN 2010-05-19 20:01:05 EDT
Description of problem:

When you make a simple mistake, such as putting in a space in an xml filename, trying to determine the root cause from the default error message is unnecessarily difficult.

Version-Release number of selected component (if applicable):

Publican v1.6.3

How reproducible:

100%

Steps to Reproduce:
1. Create a chapter XML file that contains a space in the filename.
2. xi:include this chapter file (including the space in the filename) in the [bookname].xml file.
3. Publish the book.
  
Actual results:

The following error is returned to describe the issue: 

[bookname].xml:11: XInclude error : failed build URL

Expected results:

An error message that better helps the user determine what might be causing the error. For example:

[bookname].xml:11: XInclude error : failed build URL. Check the xi:includes in the quoted file for spaces or unsupported symbols.

Additional info:

If it wasn't for another user nearby who had already experienced this error (but didn't raise a bug at the time) I don't know how long it would have taken me to diagnose this simple mistake.  A message like the one I suggested would make the
troubleshooting process much quicker. 

Is it worth considering doing the same for other commonly encountered validation errors.
Comment 1 Jeff Fearn 2010-05-26 01:41:12 EDT
The text of the message, 'failed build URL', is supplied by libxml, if you want that changed you will need to open a bug upstream.

I reformatted the error message and included the line and error numbers:

e.g.

FATAL ERROR 1605 in Users_Guide.xml on line 10: failed build URL



FYI since the href in xi:include is a URI string you need to escape spaces in it:

e.g.

wrong:

<xi:include href="Test File.xml" />

right:

<xi:include href="Test%20File.xml" />

Fixed in build 1.6.3-0.t81
Comment 2 Jeff Fearn 2010-05-26 01:53:45 EDT
I added the domain in, since it's useful.

FATAL ERROR: XInclude:1605 in Users_Guide.xml on line 10: failed build URL

Fixed in build 1.6.3-0.t83
Comment 3 Fedora Update System 2010-07-06 02:00:43 EDT
publican-2.0-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-2.0-0.fc13
Comment 4 Fedora Update System 2010-07-06 02:01:22 EDT
publican-2.0-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-2.0-0.fc12
Comment 5 Fedora Update System 2010-07-06 13:18:42 EDT
publican-2.0-0.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update publican'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/publican-2.0-0.fc12
Comment 6 Fedora Update System 2010-07-06 13:20:08 EDT
publican-2.0-0.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update publican'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/publican-2.0-0.fc13
Comment 7 Fedora Update System 2010-07-06 23:13:22 EDT
publican-2.1-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-2.1-0.fc13
Comment 8 Fedora Update System 2010-07-06 23:13:59 EDT
publican-2.1-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-2.1-0.fc12
Comment 9 Fedora Update System 2010-07-07 13:35:34 EDT
publican-2.1-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-07-07 13:40:07 EDT
publican-2.1-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.