Bug 593912 - SELinux is preventing logrotate (logrotate_t) "write" initrc_exec_t.
SELinux is preventing logrotate (logrotate_t) "write" initrc_exec_t.
Status: CLOSED DUPLICATE of bug 593913
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:8a25f387b08...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 23:10 EDT by Naoki
Modified: 2010-06-03 05:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-20 05:35:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naoki 2010-05-19 23:10:01 EDT
Summary:

SELinux is preventing logrotate (logrotate_t) "write" initrc_exec_t.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by logrotate. It is not expected that this
access is required by logrotate and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:logrotate_t:s0-s0:c0.c1023
Target Context                system_u:object_r:initrc_exec_t:s0
Target Objects                ovirt-host-register [ file ]
Source                        logrotate
Source Path                   /usr/sbin/logrotate
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           logrotate-3.7.8-2.fc11
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.12-82.fc11
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.30.5-43.fc11.i586 #1
                              SMP Thu Aug 27 21:18:54 EDT 2009 i686 i686
Alert Count                   1
First Seen                    Sun 27 Sep 2009 03:28:15 AM JST
Last Seen                     Sun 27 Sep 2009 03:28:15 AM JST
Local ID                      1174df11-7a84-4258-82fb-3d2ec8410df5
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253989695.551:48073): avc:  denied  { write } for  pid=23251 comm="logrotate" name="ovirt-host-register" dev=dm-0 ino=13764889 scontext=system_u:system_r:logrotate_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1253989695.551:48073): arch=40000003 syscall=5 success=yes exit=4 a0=82ea720 a1=8002 a2=0 a3=0 items=0 ppid=23249 pid=23251 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=3613 comm="logrotate" exe="/usr/sbin/logrotate" subj=system_u:system_r:logrotate_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,logrotate,logrotate_t,initrc_exec_t,file,write
audit2allow suggests:

#============= logrotate_t ==============
allow logrotate_t initrc_exec_t:file write;
Comment 1 Miroslav Grepl 2010-05-20 05:35:30 EDT

*** This bug has been marked as a duplicate of bug 593913 ***

Note You need to log in before you can comment on or make changes to this bug.