Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 593983 - Goldendict can't start
Summary: Goldendict can't start
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: goldendict
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Howard Ning
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 09:06 UTC by Pavel Alexeev
Modified: 2010-05-20 12:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-20 12:00:46 UTC
Type: ---


Attachments (Terms of Use)

Description Pavel Alexeev 2010-05-20 09:06:46 UTC
Description of problem:
$ goldendict 
Another GoldenDict copy started already.

$ LANG=C killall goldendict
goldendict: no process killed
$ ps aux | grep -i golden
pasha     2767  0.0  0.0   4336   728 pts/3    D+   12:57   0:00 grep --color -i golden
$ ps aux | grep -i dict
pasha     2803  0.0  0.0   4336   788 pts/3    S+   12:59   0:00 grep --color -i dict


Version-Release number of selected component (if applicable):
$ rpm -q goldendict
goldendict-0.9.0-11.20100510gitceab951.fc13.i686

How reproducible:
Always

Comment 1 Howard Ning 2010-05-20 11:27:56 UTC
Have you tried to restart? I can't reproduce on my Fedora 13 x86-64.

Comment 2 Pavel Alexeev 2010-05-20 11:32:04 UTC
How restatrt?? I try, but don't known what process I shold kill first.

Comment 3 Howard Ning 2010-05-20 11:46:37 UTC
I mean reboot your computer. It should be the problem of an unreleased lock.

Comment 4 Pavel Alexeev 2010-05-20 11:54:35 UTC
Yes, thank you.
After delete ~/.goldendict/pid file it starts.

Meantime on start it only check file pid, not check also existance of process with this pid!

Comment 5 Howard Ning 2010-05-20 11:58:58 UTC
Ok, I will close it and notify the upstream about the problem.


Note You need to log in before you can comment on or make changes to this bug.