Bug 593994 - 'CSP Feed Settings' -> Save gives exception in server log
Summary: 'CSP Feed Settings' -> Save gives exception in server log
Status: CLOSED DUPLICATE of bug 589161
Alias: None
Product: RHQ Project
Classification: Other
Component: Content   
(Show other bugs)
Version: 3.0.0
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: rhq_triage
TreeView+ depends on / blocked
 
Reported: 2010-05-20 09:55 UTC by Rajan Timaniya
Modified: 2010-05-21 15:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-21 15:26:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file (351.87 KB, text/x-log)
2010-05-20 09:55 UTC, Rajan Timaniya
no flags Details

Description Rajan Timaniya 2010-05-20 09:55:34 UTC
Created attachment 415372 [details]
log file

Description of problem:
'CSP Feed Settings' -> Save gives exception in server log.
2010-05-20 15:17:10,625 ERROR [org.rhq.enterprise.server.content.RepoManagerBean] Error processing repository [RepoDetails[name='JBoss Patches', parentRepoName='null', repoGroup='null']]
javax.persistence.PersistenceException: org.hibernate.NonUniqueObjectException: a different object with the same identifier value was already associated with the session: [org.rhq.core.domain.content.RepoContentSource#RepoContentSourcePK: repo=[Repo: id=[101], name=[JBoss Patches]]; contentSource=[ContentSource: id=[101], name=[JBoss CSP Patch Feed]]]
        at org.hibernate.ejb.AbstractEntityManagerImpl.throwPersistenceException(AbstractEntityManagerImpl.java:629)
        at org.hibernate.ejb.AbstractEntityManagerImpl.persist(AbstractEntityManagerImpl.java:218)
...

Version-Release number of selected component (if applicable):
JON build #155 - Revision: 10620

How reproducible:
Always

Steps to Reproduce:
1) Log-in to JON 
2) Click on 'Administration' -> 'Content' -> 'Repositories'
3) Click on 'JBoss Patches'
4) Click on 'JBoss CSP Patch Feed'
5) Click on 'EDIT' button of 'CSP Feed Settings'
6) Set values for 'CSP Feed Settings' and click on 'SAVE'
   Username: <USER_NAME>
   Password: <PASSWORD>
   Active: Yes
  
Actual results:
'CSP Feed Settings' -> Save gives exception in server log.

Expected results:
'CSP Feed Settings' should be save without any error/exception.

Additional info:
Please refer attached file.

Comment 1 Simeon Pinder 2010-05-21 15:26:59 UTC

*** This bug has been marked as a duplicate of bug 589161 ***


Note You need to log in before you can comment on or make changes to this bug.