Bug 594019 - Corrupted colors in framebuffer on MGA G200eW WPCM450
Summary: Corrupted colors in framebuffer on MGA G200eW WPCM450
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-mga   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 11:10 UTC by Pavel Holica
Modified: 2011-04-04 18:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-04 18:26:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
colors (58.28 KB, image/png)
2010-05-20 11:10 UTC, Pavel Holica
no flags Details
colors1 (58.28 KB, image/png)
2010-05-20 11:10 UTC, Pavel Holica
no flags Details
colors1 (21.47 KB, image/png)
2010-05-24 10:50 UTC, Pavel Holica
no flags Details
dmesg (60.26 KB, application/octet-stream)
2011-01-31 10:01 UTC, Pavel Holica
no flags Details
/var/log/messages (291.55 KB, application/octet-stream)
2011-01-31 10:02 UTC, Pavel Holica
no flags Details
Xorg.0.log (21.79 KB, text/plain)
2011-01-31 10:02 UTC, Pavel Holica
no flags Details
Xorg.9.log (22.03 KB, text/plain)
2011-01-31 10:03 UTC, Pavel Holica
no flags Details
/var/log/messages (291.55 KB, text/plain)
2011-01-31 10:03 UTC, Pavel Holica
no flags Details
dmesg (60.26 KB, text/plain)
2011-01-31 10:03 UTC, Pavel Holica
no flags Details

Description Pavel Holica 2010-05-20 11:10:29 UTC
Created attachment 415385 [details]
colors

Description of problem:
Anaconda has corrupted colors in framebuffer while booting and installed system has corrupted colors in plymouth while booting on this hardware.

Version-Release number of selected component (if applicable):
RHEL6.0-20100512.0 x86_64 Server
kernel-2.6.32-25.el6.x86_64

How reproducible:
always

Steps to Reproduce:
Start installer on this hardware
or
Start installed system on this hardware
  
Actual results:
Colors are corrupted (see attachment )

Expected results:
Colors should be ok

Additional info:

Comment 1 Pavel Holica 2010-05-20 11:10:59 UTC
Created attachment 415386 [details]
colors1

Comment 3 RHEL Product and Program Management 2010-05-20 11:25:21 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Bill Nottingham 2010-05-20 14:39:17 UTC
Are you explicitly trying to enable vesafb? If so... why?

Comment 5 Pavel Holica 2010-05-24 10:50:20 UTC
Created attachment 416083 [details]
colors1

I do not. I haven't modified command line in grub. I did installation using same approach on several different machines, and they were ok.

Comment 6 Bill Nottingham 2010-05-24 14:56:15 UTC
How are you connecting to this system console?

Comment 7 Pavel Holica 2010-05-25 15:25:28 UTC
I'm using Java iDRAC6 KVM.

Comment 8 RHEL Product and Program Management 2010-07-15 14:39:03 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 9 Matěj Cepl 2011-01-11 17:25:36 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 10 Pavel Holica 2011-01-31 10:01:14 UTC
No xorg.conf present.
Log files will follow.

Please note, that colours in X are ok, but in plymouth and tuxes in framebuffer have those weird colours.

Comment 11 Pavel Holica 2011-01-31 10:01:49 UTC
Created attachment 476152 [details]
dmesg

Comment 12 Pavel Holica 2011-01-31 10:02:11 UTC
Created attachment 476153 [details]
/var/log/messages

Comment 13 Pavel Holica 2011-01-31 10:02:48 UTC
Created attachment 476154 [details]
Xorg.0.log

Comment 14 Pavel Holica 2011-01-31 10:03:05 UTC
Created attachment 476156 [details]
Xorg.9.log

Comment 15 Pavel Holica 2011-01-31 10:03:34 UTC
Created attachment 476157 [details]
/var/log/messages

Comment 16 Pavel Holica 2011-01-31 10:03:53 UTC
Created attachment 476158 [details]
dmesg

Comment 17 Adam Jackson 2011-02-08 22:26:49 UTC
When we've seen this before it's been the firmware resetting the video hardware to paletted mode before exiting boot services, but leaving the EFI description of the hardware claiming it to be in truecolor.  Pretty sure this is a firmware bug.

Comment 19 Pavel Holica 2011-03-31 09:40:11 UTC
I'm unable to reproduce this anymore.

Comment 20 Denise Dumas 2011-04-04 18:26:48 UTC
We believe updated efi bios handling fixed this, or the bios update itself


Note You need to log in before you can comment on or make changes to this bug.