Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 594022 - SELinux is preventing /usr/sbin/abrtd "create" access on abrt.
SELinux is preventing /usr/sbin/abrtd "create" access on abrt.
Status: CLOSED DUPLICATE of bug 593906
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:a385f335182...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-20 07:18 EDT by Frank Murphy
Modified: 2010-05-28 08:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 07:57:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Murphy 2010-05-20 07:18:46 EDT
This was caused after a local policy for:
https://bugzilla.redhat.com/show_bug.cgi?id=594017


Summary:

SELinux is preventing /usr/sbin/abrtd "create" access on abrt.

Detailed Description:

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:var_t:s0
Target Objects                abrt [ lnk_file ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-1.1.2-1.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-19.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.34-2.fc14.x86_64
                              #1 SMP Mon May 17 03:51:48 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Thu 20 May 2010 12:16:25 IST
Last Seen                     Thu 20 May 2010 12:16:25 IST
Local ID                      4da812e2-1c02-4604-aa8d-de4d60a12ffc
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274354185.747:66): avc:  denied  { create } for  pid=2636 comm="abrtd" name="abrt" scontext=unconfined_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_t:s0 tclass=lnk_file

node=(removed) type=SYSCALL msg=audit(1274354185.747:66): arch=c000003e syscall=88 success=no exit=-13 a0=41e791 a1=41e933 a2=0 a3=0 items=0 ppid=2635 pid=2636 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="abrtd" exe="/usr/sbin/abrtd" subj=unconfined_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,abrtd,abrt_t,var_t,lnk_file,create
audit2allow suggests:

#============= abrt_t ==============
allow abrt_t var_t:lnk_file create;
Comment 1 Miroslav Grepl 2010-05-24 07:57:25 EDT

*** This bug has been marked as a duplicate of bug 593906 ***

Note You need to log in before you can comment on or make changes to this bug.