Bug 594027 - Library builds duplicate
Summary: Library builds duplicate
Keywords:
Status: CLOSED DUPLICATE of bug 594028
Alias: None
Product: Fedora
Classification: Fedora
Component: libevent
Version: 7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 11:37 UTC by Joe Orton
Modified: 2010-05-20 11:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-20 11:42:54 UTC
Type: ---


Attachments (Terms of Use)

Description Joe Orton 2010-05-20 11:37:06 UTC
Description:
1) libevent_extra requires symbols from libevent_core but does not have a DT_NEEDED for it

2) libevent_core and libevent_extra seem to contain exactly the same set of objects as
libevent.  Why not make libevent depend on core/extra, or vice versa?  This is a strange
waste of disk space.

Comment 1 Joe Orton 2010-05-20 11:42:54 UTC

*** This bug has been marked as a duplicate of bug 594028 ***


Note You need to log in before you can comment on or make changes to this bug.