Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 594092 - wrong users and groups creation in spec file
wrong users and groups creation in spec file
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: MAKEDEV (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
:
: 609226 (view as bug list)
Depends On:
Blocks: 593683
  Show dependency treegraph
 
Reported: 2010-05-20 10:37 EDT by Peter Vrabec
Modified: 2013-01-10 00:58 EST (History)
3 users (show)

See Also:
Fixed In Version: MAKEDEV-3.24-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:30:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2010-05-20 10:37:01 EDT
Description of problem:
Please fix user/group creation in your spec file[1]. There were problems when
(UID != GID) && (UID<200) [2]. For example:
tryitd:x:194:482:TryIt:/:/sbin/nologin

Problem was caused by change/fix of shadow-utis behaviour. useradd does not
create group with same GID as user's UID for IDs < 200 (static/reserved) unless
it's done this way:

getent group qemu >/dev/null || groupadd -g 107 -r qemu
getent passwd qemu >/dev/null || \
  useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
    -c "qemu user" qemu


This issue should be fixed as soon as possible. Note, it can't be resolved by
any update once we have RHEL6 GA. Please fix it in Fedora too. thnx.

--------
[1] https://fedoraproject.org/wiki/Packaging:UsersAndGroups 
[2] https://bugzilla.redhat.com/show_bug.cgi?id=593683
Comment 1 Chris Lumens 2010-06-07 15:23:26 EDT
Can I get either a QA ack on this so I can do a build, or a nak so I can at least plan appropriately?
Comment 3 Alexander Todorov 2010-07-01 08:39:14 EDT
The spec file for MAKEDEV-3.24-6.el6 included in 0630 nightly has:

%pre
# Add the floopy group and the vcsa user.
getent group floppy >/dev/null || groupadd -g 19 -r -f floppy
getent group vcsa >/dev/null || groupadd -g 69 -r -f vcsa
getent passwd vcsa >/dev/null || \
        useradd -r -g vcsa -d /dev -s /sbin/nologin -u 69 \
        -c "virtual console memory owner" vcsa 2>/dev/null
exit 0

Moving to VERIFIED.
Comment 4 Chris Lumens 2010-07-02 10:23:50 EDT
*** Bug 609226 has been marked as a duplicate of this bug. ***
Comment 5 releng-rhel@redhat.com 2010-11-10 14:30:46 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.