Bug 594093 - "status" directive no longer reporting correct data
"status" directive no longer reporting correct data
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.0
All Linux
high Severity high
: beta
: ---
Assigned To: Jiri Moskovcak
BaseOS QE - Apps
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-20 10:37 EDT by Jay Turner
Modified: 2015-02-01 17:52 EST (History)
8 users (show)

See Also:
Fixed In Version: abrt-1.1.2-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-03 10:17:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2010-05-20 10:37:20 EDT
Description of problem:
With the upgrade to 1.1.2-1.el6, the PID and lock files were renamed (from "abrt" to "abrtd") but the initscript was not updated.  Net result is that 'status' calls "status abrt" which finds nothing (because the pid file is 'abrtd.pid' now) and the abrtd service is incorrectly reported as not running.

Version-Release number of selected component (if applicable):
1.1.2-1.el6

How reproducible:
Always

Steps to Reproduce:
1. Update to the 1.1.2-1.el6 packages
2. Ensure the abrtd service is running ('service abrtd restart')
3. 'service abrtd status'
  
Actual results:
Will report the service is not running.

Expected results:
Should report the service is running.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.