Bug 59411 - login process and shell keeps running when telnetd exits
login process and shell keeps running when telnetd exits
Status: CLOSED DUPLICATE of bug 59029
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-07 09:07 EST by Gunther Schlegel
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-07 09:07:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gunther Schlegel 2002-02-07 09:07:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
When users login via telnet and start an application and do not log out
correctly but just press the X on their windows terminal client the telnetd
process terminates but the login process remains as well as the bash process and
the application process

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. login with telnet terminal emulation programm
2. start a program, e.g. top.
3. close the terminal emulation
	

Actual Results:  The program, bash and login processes remain with no attached
terminal

Expected Results:  The processes should terminate when telnetd exits

Additional info:

I found this behaviour on two application server systems we have, but not on my
reference 7.2 installation (in VMware, just basic setup and all errata packages
applied). 

The servers both have been upgraded from 6.2, the reference system was installed
on a plain virtual machine.
Comment 1 Elliot Lee 2002-03-08 14:03:32 EST

*** This bug has been marked as a duplicate of 59029 ***

Note You need to log in before you can comment on or make changes to this bug.