Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 594155 - wrong users and groups creation in spec file
wrong users and groups creation in spec file
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mysql (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Tom Lane
qe-baseos-daemons
:
Depends On:
Blocks: 593683
  Show dependency treegraph
 
Reported: 2010-05-20 10:39 EDT by Peter Vrabec
Modified: 2013-07-02 23:28 EDT (History)
5 users (show)

See Also:
Fixed In Version: mysql-5.1.47-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:11:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2010-05-20 10:39:47 EDT
Description of problem:
Please fix user/group creation in your spec file[1]. There were problems when
(UID != GID) && (UID<200) [2]. For example:
tryitd:x:194:482:TryIt:/:/sbin/nologin

Problem was caused by change/fix of shadow-utis behaviour. useradd does not
create group with same GID as user's UID for IDs < 200 (static/reserved) unless
it's done this way:

getent group qemu >/dev/null || groupadd -g 107 -r qemu
getent passwd qemu >/dev/null || \
  useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
    -c "qemu user" qemu


This issue should be fixed as soon as possible. Note, it can't be resolved by
any update once we have RHEL6 GA. Please fix it in Fedora too. thnx.

--------
[1] https://fedoraproject.org/wiki/Packaging:UsersAndGroups 
[2] https://bugzilla.redhat.com/show_bug.cgi?id=593683
Comment 1 Tom Lane 2010-05-20 11:16:19 EDT
Hm, isn't the consensus in bug #593683 that useradd should be fixed to preserve the old behavior?

I agree that it wouldn't be a bad idea to modify the mysql spec file to make the group ID be specified explicitly, but I hardly think this is a blocker.

BTW, are you satisfied with the way the postgresql spec file does the same thing?
Comment 2 Peter Vrabec 2010-05-24 06:11:37 EDT
Yes the consensus was to fix useradd. Nevertheless, I recommend fixing spec files too.

Since useradd is already fixed this doesn't need to be blocker.

I think postgresql does user/group creation correctly.
Comment 3 Fedora Update System 2010-05-24 19:31:51 EDT
mysql-5.1.47-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/mysql-5.1.47-1.fc12
Comment 4 Fedora Update System 2010-05-24 19:32:12 EDT
mysql-5.1.47-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/mysql-5.1.47-1.fc13
Comment 5 Fedora Update System 2010-05-24 19:32:31 EDT
mysql-5.1.47-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/mysql-5.1.47-1.fc11
Comment 7 Fedora Update System 2010-06-07 18:28:00 EDT
mysql-5.1.47-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-06-07 18:30:32 EDT
mysql-5.1.47-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-06-07 18:31:57 EDT
mysql-5.1.47-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 releng-rhel@redhat.com 2010-11-10 16:11:28 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.